• Register
  • Help
Results 1 to 5 of 5

Topic: Problems with Kontakt 2 Player

Share/Bookmark
  1. #1

    Problems with Kontakt 2 Player

    I downloaded (from Native Instruments) the updates of the Kontakt 2 player for both GPO and JABB, and installed them with all the required registration codes, but when I open the Kontakt 2 Player from within Finale and attempt to load a patch, I get the message: "This patch was generated by a newer version of Kontakt. Please upgrade your copy to load the patch." But I have the newer (newest!) version of Kontakt.

    I tried deleting the old player and then re-loading, but the same thing occurred. I even uninstalled and reinstalled GPO and JABB from scratch, with the same result. The old player still works OK from within Finale. I looked in the new Kontakt 2 folder with the new instruments, and they all seem to be there, although from within the Kontakt 2 player the file names, or at least some of the folders, appear to be different.

    Does anyone have any idea on what's going on?

    P.S. In the meanwhile, JABB vanished from the Kontakt 2 player. I think I changed one of the file locations from within the player when I was trying various solutions, but can't see how to get it back there.

  2. #2

    Re: Problems with Kontakt 2 Player

    oh my---here we go again.

    I'm sorry I have no information for you Russ, only sympathy.

    I'm waiting for the Second group of Beta Testers (I assume there was a first group before this was unleashed on the users) to wade through the problems, bugs, convoluted set up protocols et al before I upgrade.

    I wish you and the rest of the KP2 users the best of luck. I await anxiously for a happy out come.

    Randy B.
    (rbowser)

  3. #3
    Senior Member Leaf's Avatar
    Join Date
    Apr 2006
    Location
    Dallas, TX
    Posts
    2,797

    Re: Problems with Kontakt 2 Player

    Here is a reprint of what i had posted in another thread, because i was getting the same message and this fixed that problem.

    here is the way i did it on an older non intel mac powerbook:

    First installed updates without uninstalling anything, and it did not work, had a few issues... like not working!

    Then I uninstalled GPO, JABB, Finale, K2, not by using an uninstall program, but by dropping all the folders in the trash along with the icons in the dock.

    Didn't dispose of any plist's or kext's.

    Then

    1. Re-installed GPO, then the GPO K2.2.2 update (checked all the boxes on custom install)
    2. Re-installed JABB, then the JABB K2.2.2 update (checked all the boxes..)
    3. Re-installed Finale 2007, then 2007c update

    Okay something could have been wrong with that order i used, because in Finale, while attempting to load instruments from either GPO or JABB, message appeared that said something about patches being from a newer player and Kontakt update is needed.

    So i then did reinstalls of the two K2 Player updates, one for GPO and one for JABB, reconfirmed the registrations (because JABB had a little caution sign on it like the icon on this post)... and now she works.

  4. #4

    Re: Problems with Kontakt 2 Player

    Hello, Leaf--Thanks for your story.

    It's exactly the opposite of what I understand the official advice to be--They say to Not un-install anything first. But look what happened to you when you did just that.

    I KNow that many people have upgraded without any resulting problems, but it's clear from reading the scattered and multitudinous posts, and the conflicting, contradictory replies they have engendered, that many people still have big problems with making the upgrade work well for them and that straight-forward answers seem to be few and far-between.

    Eventually there will have to be a comprehensible guide for the rest of us to follow when we feel it's safe to take the upgrade.

    Meanwhile--I'm quite happy with GPO and JABB as they were originally installed, with the old Kontact player.

    Randy B.
    (rbowser)

  5. #5
    Senior Member Leaf's Avatar
    Join Date
    Apr 2006
    Location
    Dallas, TX
    Posts
    2,797

    Re: Problems with Kontakt 2 Player

    Quote Originally Posted by rbowser-
    Hello, Leaf--Thanks for your story.

    It's exactly the opposite of what I understand the official advice to be--They say to Not un-install anything first. But look what happened to you when you did just that.

    I KNow that many people have upgraded without any resulting problems, but it's clear from reading the scattered and multitudinous posts, and the conflicting, contradictory replies they have engendered, that many people still have big problems with making the upgrade work well for them and that straight-forward answers seem to be few and far-between.

    Eventually there will have to be a comprehensible guide for the rest of us to follow when we feel it's safe to take the upgrade.

    Meanwhile--I'm quite happy with GPO and JABB as they were originally installed, with the old Kontact player.

    Randy B.
    (rbowser)
    You are right, I spoke too soon. I started having crashes whenever i tried to start a new doc from the set up wizard. I thought it was caused by 2007c update, so I redid Finale2007 without updates and there was no crashing.

    Then, the support people at Finale asked what were the contents of my hard-drive>Library>Audio>Plugins>Components folder. There was six items and two of them were not from Garritan Products or Finale. Those two were midiO.component and Crystal.component. They suggested I move those to a temp folder to see if one of them was causing the crashes. Since I had installed these but never used them, i sent them to the trashcan and anything else on my computer that said midiO or Crystal.

    When I tried to empty trash, the computer said it could not delete Crystal because it was being used. I then tried to quit Finale and had to do a force quit, but after that it would delete.

    Then I reinstalled the Finale 2007c update and now no crashes. GPO or Jabb or both load fine from the Kontakt2 player using the wizard now, and thats without having manually moved any files from GPO or JABB to Finale.

    Rather than throwing those in the trash, i should have done them one at a time using a temp folder to isolate which one was the prob, but didn't think of that until too late. But all is well now since Finale works, and it was probably Crystal since that was the one being used somehow by Finale.

    I wonder if the other people that were having crashes before have Crystal or MidiO on their computers, maybe i should start a thread.

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •