• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Topic: K2 Failing to Appear as AU plugin in Logic or DP

Share/Bookmark
  1. #1
    Moderator
    Join Date
    Oct 2000
    Location
    Orcas Island
    Posts
    11,454

    K2 Failing to Appear as AU plugin in Logic or DP

    Some have reported that Kontakt 2 Player is appearing as a fully authorized standalone application, but NOT as a plugin in Logic Pro. NI has just provided a work around.

    For those experiencing this problem, try doing this:

    go to Mac HD>Library>Audio>Components and find the Kontakt Player 2 component.

    Throw this in the trash.

    Then install the Kontakt Player 2.2.3 update again to replace the component.

    Hopefully this will fix the problem.

    Gary Garritan

  2. #2
    Moderator
    Join Date
    Oct 2000
    Location
    Orcas Island
    Posts
    11,454

    K2 Failing to Appear as AU plugin

    If your NATIVE INSTRUMENTS plug-ins are not showing up properly in Digital Performer, first make sure that they are present in the correct folder.

    The plug-ins are in the folder
    • Macintosh HD>Library>Audio>Plug-ins>Components.
    If the plug-ins are present in the correct location but still not showing up in Performer, then you may need to completely re-scan your plug-ins in DP by deleting the Audio Unit Info Cache file.

    Quit Digital Performer, then follow these instructions:

    1. Press ‘Apple-F’ on your computer to Find files.

    2. Along the top edge of the Search window, you should see locations on your computer to search, for example ‘Servers Computer Home Others’ and so on. Make sure you click ‘Computer’ here so that you will be searching the files on your entire machine.

    3. Click the drop-down menu that says ‘Kind’ and change it to ‘Name.’

    4. In the search box to the right of ‘Name Contains,’ type 'Audio Unit Info Cache.'

    5. Drag this file into the Trash and empty it, then start Digital Performer again and it will rescan all of your Audio Units.

    If the plug-ins are still not showing up after this, another likely reason (under OS X only) might be that some of them need to be updated to Universal Binary versions for Intel Mac compatibility.

  3. #3

    Question Re: K2 Failing to Appear as AU plugin in Logic or DP

    Help! I have checked out all of this advice, and yet still I see kontakt as a Plugin in DP, but no GPO sounds. When I dropped the GPO library into the Kontakt Instruments folder, the sounds showed up in the plugin, but I got the message that they could not load.

    I am able to open GPO as a standalone, and that is what I expect to see as a plugin, but I am seeing a different version of Kontakt.

    what am I doing wrong?
    Thanks

  4. #4

    Re: K2 Failing to Appear as AU plugin in Logic or DP

    i have tried Garys suggestion at the top of this thread and still do not see the plug in when im in Logic pro. Im pulling my hair out as can use it as a standalone and have access to some great new sounds i just got but cant get at them in the place i want, ie logic.
    Any other ideas or where i can go with this one?
    thanks

  5. #5

    Re: K2 Failing to Appear as AU plugin in Logic or DP

    i'm having a similar problem--in digital performer (5.1) kontakt 2 player shows up as an instrument which can be added in an instrument track, but cannot serve as an output for any of the midi tracks.

    any suggestions?

  6. #6

    Re: K2 Failing to Appear as AU plugin in Logic or DP

    This thread is a few months old, but it never got resolved. I am having the same problem: JABB shows up in the Instrument track but the MIDI tracks have no access to the instrumennt, and I can't see the instrument plug in either.

    any solutions?

    Thanks

    Pablo

  7. #7

    Re: K2 Failing to Appear as AU plugin in Logic or DP

    Quote Originally Posted by Contrabajo View Post
    This thread is a few months old, but it never got resolved. I am having the same problem: JABB shows up in the Instrument track but the MIDI tracks have no access to the instrumennt, and I can't see the instrument plug in either.

    any solutions?

    Thanks

    Pablo
    Hello Pablo -

    First, I want to welcome you here to the Garritan forums. It is my hope that you find these forums friendly, supportive and informative, and that you visit here often.

    I might be able to help you. First, though, I need more information. Which sequencer program are you using, Logic or DP? I'm only familiar with the Logic Pro 8 version. Unfortunately, someone else will need to help you if you use DP. Also, which version of JABB are you using? The newer version comes with the Kontakt 2 Player.

    What will also be helpful is if you provide information regarding your type of computer (Mac? PC?), operating system (Mac OX - Tiger?, Leopard?; PC - XP, etc., etc.). The more information provided, the better the chance that someone can provide more appropriate support for your situation.

    Again, Welcome. Hope I/we can help you out.

    Ted
    Music and humor are healthy for the soul.

  8. #8

    Re: K2 Failing to Appear as AU plugin in Logic or DP

    I will step in for Pablo here as it looks like he didn't reply?

    I'm using an iMac G5 with Leopard and Logic 8. My issue is somewhat similar but the difference is I can open Kontakt both as a standalone AND a plug-in but neither of them will play. MIDI is working, it is synched with Logic but no sound is triggered. Everything worked prior to doing a Time Machine restore. GPO was the only program that didn't work after this, it thought it was a new system, which is frustrating as, after owning GPO for 5 years I've had to go through the nightmarish process of getting a new serial and registration number every single time the slightest change on my system is made when not a single other application has required the same. Every time I load Logic I get the message that GPO is not registered (it is, as I stated above) but I open the standalone and I DON'T get that message (it still doesn't play though). The Ambience plug-in does not work no matter how many times I install it. I've cleared preferences for Logic, for Service Center, for Kontakt player, I've tried using the original Kontakt player which gives the error "Cannot load patch...blah blah blah...". In essence, I've done just about everything. My next step is to reinstall Logic but I know that will be a nightmare because I'm positive GPO will need a reinstall too which will bring the whole serial/registration nightmare back.

    I've said this before on these forums and I hate to be negative but if GPO wasn't such an outstanding product I'd never use it again simply because I despise Native Instruments. NI's tech support is awful, they don't listen to the problem, they have always tried to turn it around to being something I've done wrong. I'm an Apple certified technician, I work on Macs all day long, it's my JOB to fix Macs and ensure they work correctly. Sorry but my system is NOT the issue.

    Anyway, sorry that turned in to a rant. I'm very tired of dealing with this. I thought Quark was the most frustrating software ever. Then I got an NI product!

    Any help would be great if anyone WANTS to help me now that I've basically screamed my head off!!

  9. #9

    Re: K2 Failing to Appear as AU plugin in Logic or DP

    Has anyone solved the problem of using GPO and JABB in Logic 8??

    They work ok ion Garage Band but are are not seen in Logic8..

  10. #10

    Re: K2 Failing to Appear as AU plugin in Logic or DP

    A post by Jay Asher pointed me in the right direction... THANK YOU, Jay

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •