• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Topic: MP3 File Provided for cc64 Problem

Share/Bookmark
  1. #1
    Senior Member 4209fr's Avatar
    Join Date
    Apr 2006
    Location
    Houston, Texas
    Posts
    121

    MP3 File Provided for cc64 Problem

    This is sort of a duplicate thread for my original cc64 question thread. I haven't received any Replies since it was posted a couple of days ago, even though a couple of dozen people have looked at it. I thought that it might help to have a short MP3 file of what is happening for a better understanding.

    I am successfully using cc64 (for legato or slurred notes) with JBB and CMB (Kontakt 2 Player). I started to 'refine' a piece that I have been working on since early this year. It is basically a string quartet using GPO (Kontakt 1) Solo instruments. (I am having a problem with Native Instruments Service Center offering the update to Kontakt 2 for GPO. Hopefully this will be resolved in a couple of days, but I don't think that this is the problem). The polyphony =1. "Options" set to "No S. . . - midi controller".

    I enter the cc64 in this piece the same way that I do for JBB and CMB pieces (where it works OK). I use (near) 127 for ON and (near) 0 for OFF. I place the 'pointers' at about the midpoint of the note that begins or ends the 'slur' (in the example MP3, it is a 3 note slur beginning on the second note (the second note is articulated; the third and fourth notes are not). All notes in the example are 1/8th notes. I have overlapped the 2nd and 3rd notes by a 1/32nd with their following neighbors.

    The problem is that the sound significantly overlaps to the next note. It doesn't matter if I make a gap between notes, or butt them up against each other or overlap the appropriate ones. As long as the cc64 pointers are there, the sound overlaps.

    I had originally (mistakenly) entered the legato as cc68, but I do not have Notation software. So when I went back to work on this piece, I noticed that there was no legato and discovered my mistake. I "Interpolated" (changed) the cc68 pointers to cc64 pointer via Sonar. This is when the overlapping sound began. I then completely Deleted all cc64 (I checked to make sure that there were no cc64 indicated in the Controller Event List for the (midi) track I am trying to find a "fix" on. Then I re-entered a cc64 (pair) at the phrase in the example. I still get the overlapping sound.

    Obviously, I can do no further work with this rather large piece until I find a solution to what is happening here. I need to know what the problem is and what to do to fix it and be able to incorporate legato in the same manner that I can with JBB and CMB.

    Thanx for any help.

    Frank

    Example:
    http://www.geocities.com/rg4209rg/audio/cc64Prob.mp3
    Frank Newman - Houston, Texas, USA, Earth, Milky Way (for our 'extended' viewership)
    Vista Ult SP2, i7 chipset, 12Gb, 500Gb (int) + 1 & 1.5Tb ext., E-MU 1820, Sonar 8.5PE, VSampler, CME UF5, AcousModules (for 3D playback), GPO/JBB/CMB

  2. #2

    Re: MP3 File Provided for cc64 Problem

    I don't know if you've tried this, but one thing I would do is make sure that it is interpreting the cc64 as legato and not sustain pedal data.

    I think to do this (assuming you're using Kontakt Player 2) you go into the instrument edit mode by clicking on the gears on the left. Then under the controller tab, set "Midi Controller #64 (sustain pedal) acts as" to "cc only" and see if that helps.

    --Richard

  3. #3
    Senior Member 4209fr's Avatar
    Join Date
    Apr 2006
    Location
    Houston, Texas
    Posts
    121

    Re: MP3 File Provided for cc64 Problem

    Richard -
    Thanx for the Reply. Currently, with GPO, I am not able to use Kontakt 2 (can't get the "update" option for it on NI Service Center), so, I am using Kontakt (1). I double-checked the "Options" to see that it indicated "No Sustain . . . CC Controller", as opposed to "Sustain . . . " or "No Sustain . . . CC Switch".

    I haven't looked at what you mentioned since I got Kontakt 2 with JBB and CMB several weeks ago, but it must be in the proper position since the legato works with those libraries. Come to think of it, though, this problem just cropped up since I installed Kontakt 2 with the new libraries. (But, I'm not sure that I was actually programming a correct legato before. So I don't know that I can say that I definitely know it was working with Kontakt (1) before).

    Frank
    Frank Newman - Houston, Texas, USA, Earth, Milky Way (for our 'extended' viewership)
    Vista Ult SP2, i7 chipset, 12Gb, 500Gb (int) + 1 & 1.5Tb ext., E-MU 1820, Sonar 8.5PE, VSampler, CME UF5, AcousModules (for 3D playback), GPO/JBB/CMB

  4. #4

    Re: MP3 File Provided for cc64 Problem

    I know you mentioned that you did change the C64 to "cc only" but what I am hearing in your example is exactly what one gets when the legato controller is set to "normal sustain". Perhaps you are using the instrument patches from the notation folder by mistake.
    Kind Regards

    Louis Dekker
    My Music Site

    Pour être grand, il faut avoir été petit.

  5. #5
    Senior Member 4209fr's Avatar
    Join Date
    Apr 2006
    Location
    Houston, Texas
    Posts
    121

    Re: MP3 File Provided for cc64 Problem

    Louis -
    You may have hit it, there. In my vast ignorance of things, when I saw the updates for Notation programs, I didn't understand what they were and thought that they might add some features to the regular GPO. So I may very well have used Notation instruments in this piece. I will go and check it out. I will report back - maybe this evening, but by tomorrow, for sure.

    Thanx for the suggestion.

    Frank
    Frank Newman - Houston, Texas, USA, Earth, Milky Way (for our 'extended' viewership)
    Vista Ult SP2, i7 chipset, 12Gb, 500Gb (int) + 1 & 1.5Tb ext., E-MU 1820, Sonar 8.5PE, VSampler, CME UF5, AcousModules (for 3D playback), GPO/JBB/CMB

  6. #6
    Senior Member 4209fr's Avatar
    Join Date
    Apr 2006
    Location
    Houston, Texas
    Posts
    121

    Re: MP3 File Provided for cc64 Problem

    OK, I Deleted the existing strings and made sure that I used the non-Notation instruments - Solo strings. I checked that the Sustain Mode was for "No Sustain - CC Controller" (or CC only).

    It is possible that I may have had Notation instruments loaded, but the problem still exists, if not slightly altered. Before I got a significant overlap of the first note's sound when the second started. It was the same length of overlap no matter how much of a gap I had between notes or how much overlap I had with the notes.

    Now it acts like there is no cc64 at all (even though the pointers are clearly there). If there is a gap between notes, then there is a gap in the sound. If the notes are butted against each other, then there is a slight articulation (since the velocity is around 40 or 48). If there is overlap between notes, then the amount of overlap is the amount of sound that overlaps - short overlap gives a minimal overlap in sound; a lengthy overlap sounds like the MP3 example. So, like I say, it now behaves like there is no cc64 in effect.

    I also tried the different Sustain Modes. Both "Sustain . . ." resulted in something like the MP3 example. Both "No Sustain . . ." resulted in what I described above. I put it back into the 'CC Controller' mode.

    So, Houston, "we still have a problem", although it appears that it is slightly different in nature.

    Thanx, again, for your suggestion, Louis.

    Frank
    Frank Newman - Houston, Texas, USA, Earth, Milky Way (for our 'extended' viewership)
    Vista Ult SP2, i7 chipset, 12Gb, 500Gb (int) + 1 & 1.5Tb ext., E-MU 1820, Sonar 8.5PE, VSampler, CME UF5, AcousModules (for 3D playback), GPO/JBB/CMB

  7. #7

    Re: MP3 File Provided for cc64 Problem

    Quote Originally Posted by 4209fr
    The polyphony =1. "Options" set to "No S. . . - midi controller".

    [/URL]
    BTW you shouldn't set the solo strings to 1 voice polyphony, you should leave them at default.....they work differently from other monophonic instruments like WWs....

    Sorry to hear that you still have a problem. I'm sure it will be sorted out soon....
    Kind Regards

    Louis Dekker
    My Music Site

    Pour être grand, il faut avoir été petit.

  8. #8
    Senior Member 4209fr's Avatar
    Join Date
    Apr 2006
    Location
    Houston, Texas
    Posts
    121

    Re: MP3 File Provided for cc64 Problem

    Louis -
    Well, actually the Polyphony is set at the default, which reads "1/2". So, maybe Polyphony is not exactly "1", but I have not noticed it to be anything but "1/2".

    To me, the Manual is a little confusing about Solo String instruments. Under "Other Controls - Mono Mode for Solo Instruments", it says, "With solo instruments . . . connected notes (slurred and legato) with the pedal depressed", which I assume is also accomplished by making a set of cc64 pointers in a 'controller map' and overlapping the legato notes. Under "Special Controls for Specific Instruments - Solo Strings - Alternating Bowstrokes", it says, " . . . pedal switching is used to simulate alternating up and down bow strokes." But, I assume that for this to work, you have to have the "Options" set to "No Sustain - Pedal switching", and, you would not have the "CC controller" available.

    Oh, well. I hope that some other ideas are forwarded. I certainly hope that one is the answer, since I have tried everything that I can think of. And, I really can't do much of anything more with this piece until this problem is solved. It is still in a very 'raw' form.

    Frank
    Frank Newman - Houston, Texas, USA, Earth, Milky Way (for our 'extended' viewership)
    Vista Ult SP2, i7 chipset, 12Gb, 500Gb (int) + 1 & 1.5Tb ext., E-MU 1820, Sonar 8.5PE, VSampler, CME UF5, AcousModules (for 3D playback), GPO/JBB/CMB

  9. #9

    Re: MP3 File Provided for cc64 Problem

    Quote Originally Posted by 4209fr
    Louis -
    Well, actually the Polyphony is set at the default, which reads "1/2". So, maybe Polyphony is not exactly "1", but I have not noticed it to be anything but "1/2".
    Polyphony doesn't say 1/2, it says 0/4 for solo strings and 0/32 for section strings when the instrument is loaded but not played. The number before "/" is the currently playing voices (=samples), the number after "/" is the maximum playing voices. Leave it at default. With strings you don't get monophonic legato playing. You make a tiny note overlap and depress CC#64 (>=65) during the overlap. CC#64 >= 65 removes the attack from the sample for a seamless legato transition. With longer overlaps both notes will sound simultaneously, no matter the value of CC#64. That's perfectly normal and the "only" way to play chords or divisi legato.

    The paragraf about Mono Mode is for wind instruments, although this is not specifically stated.

  10. #10
    Senior Member 4209fr's Avatar
    Join Date
    Apr 2006
    Location
    Houston, Texas
    Posts
    121

    Re: MP3 File Provided for cc64 Problem

    Nickie -
    My household is being far too noisy this evening for me to evaluate whether or not my legato is working when employing your instructions. So I will have to try it in the morning when things are quiet.

    But, in the meantime, maybe you can further explain to me the 'proper' technique for using cc64 for legato with string instruments using Kontakt (1). I have been receiving guidance from Randy Bowser concerning the way to do legato for monophonic instruments using Kontakt 2. Apparently, it is different from the way it should be done with strings and Kontakt 1.

    I typically use (for midi entry) 96 ticks per quarter note. So I would presume that a small overlap would be 2 or 3 ticks. You seem to indicate that the Legato On (cc64 > 64 - I use something close to 127) should be placed AFTER the Note On of the first note that is actually slurred. I presume that the Legato On is effective until you place another 'pointer' with a Value < 64 (I use something close to 0), so that every note until the Legato Off has its attack disabled.

    I guess that my question about this is how is the first slurred note (the second note that would be under the 'slur curve') have its attack disabled if the Legato On comes after that note's Note On? In other words, if the first slurred note starts at time :000 and the Note Off for the first note (which you are overlapping the second note by a small amount - in my example, by 3 ticks) and you place the Legato On at time :001 or :002 (where the notes overlap), how is the second note's attack defeated if the instruction to do so comes 1 or 2 ticks after its Note On? (Is my question "clear as mud"?). To me, it makes sense to have the Legato On at some point before the next note's Note On, which is how (as I am given to understand) it is done with Kontakt 2 instruments of JBB and CMB.

    Will you please give me some more instruction on the correct technique for utilizing legato with GPO strings and Kontakt 1? (I won't be able to try this out until tomorrow, though).

    Thanx for the help.

    Frank
    Frank Newman - Houston, Texas, USA, Earth, Milky Way (for our 'extended' viewership)
    Vista Ult SP2, i7 chipset, 12Gb, 500Gb (int) + 1 & 1.5Tb ext., E-MU 1820, Sonar 8.5PE, VSampler, CME UF5, AcousModules (for 3D playback), GPO/JBB/CMB

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •