• Register
  • Help
Results 1 to 3 of 3

Topic: GigaStudio receives MIDI but won't play samples

  1. #1

    GigaStudio receives MIDI but won't play samples


    I hope someone can help me. The short version of my problem is GigaStudio 3 is receiving MIDI but not playing the loaded sample.

    I have 3 Windows XP Pro computers, 2 Custom VisionDAW and 1 Laptop, lots of extra drives and sample libraries.

    Computer 1. DAW has Sonar 7 PE, Sibelius and Halion (Broadway Big Band)

    Computer 2. DAW has GS3 Orch and Kontakt 2 (and most of the libraries - VSL, Sonivox, Garritan and others)

    Computer 3. Laptop has Kontakt 2 and Halion with the Sonivox and BBB samples on an external hard drive

    All communicate with MIDIoverLAN

    The Laptop works perfecty playing either K2 (Sonivox Orchestra) or Halion (BBB when MIDI is sent from Sonar on Computer 1 - no problems.

    I can also use Halion on Computer 1 to play the BBB in Rewire mode (which is why it is there).

    On Computer 2, Kontakt 2 works perfectly playing it's samples when MIDI is sent from Sonar on Computer 1


    Gigastudio is definitely receiving the MIDI from Sonar on Computer 1. Not only are the ltlle MIDI lights flashing but the MIDI Monitor view actually shows the MIDI note numbers, controllers, program changes, etc., when MIDI is sent from Sonar or via keyboard. However, the little on-screen piano keyboard doesn't move and I hear no sample playing. If I click on the on-screen keyboard with the mouse, it depresses, the sample plays and I hear it. I am certain the MIDI assignments are correct because I have checked them many times and used them correctly with the other programs. I have gone through all the Configuration Manager and GS settings I can think of and checked the manual, the Audio Outputs, DSP setting, the firewall settings, etc. as well as worked through this with a friend who also uses GS. We are mystified.

    I'm sure there is a simple setting somewhere that I am missing but I just can't find it. If anyone has an idea, I would truly appreciate it. Thank you for your time.

    Be Well,


  2. #2

    Re: GigaStudio receives MIDI but won't play samples

    Hey Jimmy,

    I use Cubase, so I can only think in terms of analogy...

    When I create a new MIDI track in Cubase, I must set the MIDI output for that MIDI track to "Giga: Port 1 / Control," and then set the channel to the appropriate Giga channel.

    Is there something similar that you have to do in Sonar? Have you done it?


    When I create a new MIDI track, Cubase defaults to velocity/volume=0 . . . does Sonar? If so, try raising the value up to 127 and see whether that makes a difference...


    If you don't launch Sonar, and merely use Giga in standalone mode, does your MIDI keyboard trigger samples properly?

    — alanb




  3. #3

    Re: GigaStudio receives MIDI but won't play samples

    OK, I found it!

    Despite the fact that, in the Configuration Manager, all the ports are set correctly, I had to change each one and then immediately change it back, then hit Apply. It's as if I had to tell GS which ports to use even though they were already selected. In any case, I did this and it worked so all is good.

    Be Well,


Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts