• Register
  • Help
Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Topic: Got the Crackles

Share/Bookmark
  1. #1

    Got the Crackles

    I'm running into an issue with GPO and Finale 2008. Crackles! Lovely little things that can really ruin your day. I'm working on a project that is using mostly strings plus flute, oboe and french horn (not all at one time). For a more realistic string sound I'm doing the following: For Violin 1 I have Gagliano 1-3 and Stradivari 1-2 together on one channel, Violin 2 has Stradivari 3 and Guarneri 1-3 on another channel and so forth. I had used the Violin 1 & 2 Lush as well for a fuller sound, but the crackles got way too bad. However, the crackles come back anyway whenever the solo horn plays. I am using the Kontakt 2 player. Under the DFD setting under options I have the amount of memory set at around 60 MB (had another problem earlier and was told not to set this too high). I have tried lowering this and raising it, but it made no difference. I've got 4 gig of ram on my computer so I should have more than enough ram. My sound card (M-Audio 2496) has the buffer rate set at 256 and a sample rate at 44000. Latency is at 6 ms. Is there some other setting I should be looking at? No other program is running other than anti-virus software. Going back to stone knives and bearskins for writing music would really be a drag!

    Gary
    Serenity Musician Productions (Gary A.)

    Lenovo ThinksStation S30, Windows 10 Professional 64-bit, 20 gig ram, 2 terabyte hd., M-Audio Fast Track, Finale25, Sonar Professional

  2. #2

    Re: Got the Crackles

    Try increasing the buffer size to 512 or 1024. This will increase your latency, though with playback from Finale (opposed to recording in live), this is hardly an issue.

    Reegs

  3. #3
    Senior Member
    Join Date
    Mar 2006
    Location
    Perth, Western Australia
    Posts
    233

    Re: Got the Crackles

    Hi

    Firstly, do you still get the crackles when saving to audio? If not, then things can be salvageable.

    A couple of things to try.

    1) After playing through the piece once, go to each instance of Kontakt and from the Purge button, select "Update Sample Pool". This will purge all unused samples from memory, decreasing overheads. This may have some impact.
    2) From the playback options, turn off scrolling.
    3) Reduce the polyphony settings of some of your instruments. For example, the Gagli player 1 has a max polyphony set to 64. try dialling that down to 16

    I'm assuming that you're running an Intel based computer -
    If you are looking at scores of this size frequently, you may want to have a look at your hardware. Check out the specs of your memory. If you are not already there, upgrade the memory of your computer to the fastest ram that it can handle. A lot of package machines now are coming out with Core 2 Duo CPUs but hobbled with slow Ram which is (to my mind) criminal. For a machine with DDR Memory, get 400Mhz Ram. for a machine with DDR2 Ram, go to at least 800MHz. It is amazing the difference that memory speed can make on playback.

    Hope this helps..

    Cheers...

    Daz :0)

  4. #4

    Re: Got the Crackles

    Quote Originally Posted by Reegs View Post
    Try increasing the buffer size to 512 or 1024. This will increase your latency, though with playback from Finale (opposed to recording in live), this is hardly an issue.

    Reegs
    Hi Reegs!

    Thanks for the help. I increased the buffer size, first to 512 then to 1024, and latency is now up to 23. That seemed to help a little bit, but the crackle did happen a few times anyway. One thing I did, as a temporary measure, was to drop the extra parts for the cello and contrabass and just use the lush setting from the cello and bass section strings. I then added the lush setting back to the violins and violas. It's not the optimum setting, but at least it works so far. I will know more as I continue working on this piece and the instrumention gets thicker. Thanks Reegs!

    Gary
    Serenity Musician Productions (Gary A.)

    Lenovo ThinksStation S30, Windows 10 Professional 64-bit, 20 gig ram, 2 terabyte hd., M-Audio Fast Track, Finale25, Sonar Professional

  5. #5

    Re: Got the Crackles

    Oh the things one learns from you all. Thanks so much Daz!!!

    Quote Originally Posted by darrob View Post
    Hi

    Firstly, do you still get the crackles when saving to audio?
    Haven't tried that as yet. Lot of music to rewrite first.

    1) After playing through the piece once, go to each instance of Kontakt and from the Purge button, select "Update Sample Pool".
    That was a cool tip. When I updated them the memory allocation did go down quite a bit on each part. One thing that I thought was odd was why, for example, Cello 1 Player One would use 330.58 kB of memory and Cello 2 Player Three would use 1.76 MB even after doing the update. I've never paid attention to this before (never even thought about it).

    2) From the playback options, turn off scrolling.
    Done.

    3) Reduce the polyphony settings of some of your instruments. For example, the Gagli player 1 has a max polyphony set to 64. try dialling that down to 16.
    All of the individual violins/violas, etc. are set at 4. All of the lush strings are set at 16. I added the individual parts back in for the cello and basses hoping the suggestions you and Reeg have given me would do the trick. Unfortunately the crackle still happens once in a while. What if I eliminated the lush strings and upped the polyphony on the individual instruments? What are your thoughts?

    I'm assuming that you're running an Intel based computer -
    If you are looking at scores of this size frequently, you may want to have a look at your hardware. Check out the specs of your memory. If you are not already there, upgrade the memory of your computer to the fastest ram that it can handle. A lot of package machines now are coming out with Core 2 Duo CPUs but hobbled with slow Ram which is (to my mind) criminal. For a machine with DDR Memory, get 400Mhz Ram. for a machine with DDR2 Ram, go to at least 800MHz. It is amazing the difference that memory speed can make on playback.
    Yep, it is an Intel based computer...HP Pavillion with Dual core. It is running DDR2 RAM, but the max with this motherboard is 533 MHz so that's the best I can do. I'm going to try a couple other things and I'll get back to you and let you know how things turn out. Thanks so much for the tips!!!

    Gary
    Serenity Musician Productions (Gary A.)

    Lenovo ThinksStation S30, Windows 10 Professional 64-bit, 20 gig ram, 2 terabyte hd., M-Audio Fast Track, Finale25, Sonar Professional

  6. #6
    New Member
    Join Date
    Dec 2007
    Location
    Otago Peninsula (S.I.)
    Posts
    10

    Re: Got the Crackles

    Hi,

    I had a baffling problem, not 'crackles', but slight 'blips' in the sound-quality of material I took out of 'Quickscore' as 'wave' files. I finalise what I have written, then copy, as a 'wave' file, each instrument-group to a
    holding-file, pending a down-mix in 'Reaper'. However, the quality was not great, with little audible disturbances every few seconds, on all tracks.
    Magnifying these in an audio-editor, showed them to be tiny 'steps' on
    the edge of the instrument's modualtion-envelope(s), not discontinuities in the sound. Changing from my sound-card's 'generic' system to ASIO made a world of difference and now the quality is much improved. I did have 'issues' with obtaining sound conduits capable of handling 'wave'
    files. The solution, turned out to be to activate another (and totally unrelated), audio program and to select the 'nvidia' option, thus preventing the channel(s) from being hogged, by default, by something else I had been using. That had the effect of leaving the channel 'open' and hence available for transfer of my 'wave' material. A bit 'Mickey-mouse' it might be, but it works.

    One day, I'll get around to investigating the matter more fully; meanwhile, there's music to be made.

    Ian Smith
    IAN SMITH

  7. #7

    Re: Got the Crackles

    Quote Originally Posted by IAN JAMES SMITH View Post
    Hi,

    Changing from my sound-card's 'generic' system to ASIO made a world of difference and now the quality is much improved.
    Using ASIO is definitely the way to go. I've had a few times when I've either changed a sound card or did an update and, for some reason Kontakt player changed to something other than ASIO and the sound was really bad. Very strange. Must be caused by the same gremlins who steal the socks out of my dryer!

    meanwhile, there's music to be made.

    Ian Smith
    Oh so true! Wish I didn't have to work for a living. Writing music is much more fun!

    Gary
    Serenity Musician Productions (Gary A.)

    Lenovo ThinksStation S30, Windows 10 Professional 64-bit, 20 gig ram, 2 terabyte hd., M-Audio Fast Track, Finale25, Sonar Professional

  8. #8
    Senior Member
    Join Date
    Mar 2006
    Location
    Perth, Western Australia
    Posts
    233

    Re: Got the Crackles

    Quote Originally Posted by serenitymusician
    Using ASIO is definitely the way to go.
    Hi

    Unfortunately, Finale does not use ASIO. Rather, it uses DirectSound. The strength of ASIO is the low latency when directing MIDI input from a midi device (keyboard, another computer etc) to an audio type player (eg a sampler) in real time. There is no real benefit when playback is initiated from within Finale.
    An example of the supremacy of ASIO over DirectSound is when you are using a keyboard to play in real time with backing provided by a midi app.

    Just out of curiosity, what model Pavillion do you have?

    Cheers...

    Daz :0)

  9. #9

    Re: Got the Crackles


    Unfortunately, Finale does not use ASIO. Rather, it uses DirectSound.
    There's something I was never aware of before. That does explain a lot.
    Just out of curiosity, what model Pavillion do you have?
    I'll have to get back to you on that tonight.

    Gary
    Serenity Musician Productions (Gary A.)

    Lenovo ThinksStation S30, Windows 10 Professional 64-bit, 20 gig ram, 2 terabyte hd., M-Audio Fast Track, Finale25, Sonar Professional

  10. #10
    Senior Member
    Join Date
    Mar 2006
    Location
    Perth, Western Australia
    Posts
    233

    Re: Got the Crackles

    Hi

    I've just had a thought.

    Are you using Vista? If so, try turning off the Aero interface. This may free up additional resources.

    Cheers...

    Daz :0)

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •