• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Topic: Adding control event #64 to produce legato

  1. #1

    Adding control event #64 to produce legato

    [Let me know if this is the wrong forum to post this message]

    I'm trying to insert an event in the event list to produce Legato:
    Page 40 of the Garrritan Personal Orchestra manual says:

    Sustain Pedal Legato Controller CC# 64 – Legato
    This controller is used to create legato lines. You can use and external sustain pedal to control the legato function or it can be entered in your sequencer by hand. Pedal up (cc#64, value 0-64) is detache, pedal down (cc# 64, value 65-127) for legato.

    I added the following event before the notes I want legato (the notes are also Ch 1):
    Status Control
    Ch 1
    Num 64
    Val 127

    and yet the notes that follow it do not play as legato. The MIDI notes do not overlap. Is what I'm doing correct? Is there something else I need to do?

  2. #2

    Re: Adding control event #64 to produce legato

    I dont think it works if there is a gap between the notes, there need to follow on.

  3. #3

    Re: Adding control event #64 to produce legato

    Doug, CC64 in GPO is a very clever feature that shaves off the "attack" portion of the sample while the sustain pedal is held down. Since a legato line only has one breath, or bow or whatever, every note is connected, hopefully by you. The sustain pedal does not connect notes, you have to do that.

    To use the legato feature properly, for example, let's say we have four notes that are to be played legato,... your first note would be played without the sustain pedal on, then, sometime before the next note begins you hold down the sustain pedal for the full duration of the rest of that legato phrase.

    The next line after a breath would not have the pedal depressed so that the initial attack of air or bow is heard.

    It is imperative to use this feature, and use it properly for realistic sound on all woodwinds, brass and strings in GPO.

    It is a very cool thing that I believe Tom Hopkins created.

  4. #4

    Re: Adding control event #64 to produce legato

    Thanks, that makes sense. That clears up how legato works for me. Thanks so much for your help.

    When I try to apply CC#64 in Logic 8 to a set of four overlapping notes, the "attack" portion of the notes that follow it do not seem to go away. Here's my event list:

    Position Status Ch Num Val Length
    1 4 1 90 Note 1 C3 80 2 0140
    1 4 1 95 Control 1 64 127
    2 2 1 90 Note 1 D3 80 2 0140
    2 4 1 90 Note 1 E3 80 2 0140
    3 4 1 90 Note 1 F3 80 2 0140

    I'm kind of a novice at this.
    I must be doing something wrong. Ideas?
    Is there something else I must set?


    P.S. Nice piece of yours "Transitions in Life"

  5. #5
    Senior Member
    Join Date
    Nov 2004
    between this place and that place

    Re: Adding control event #64 to produce legato

    sounds like the same thing in Xsamples Solo strings for Finale,Sibelius, and use in a sequencer.
    Create a controller lane, draw in Controller 68 velocity 127(meaning it's on)
    underneath notes you want legato, then next notes where the legato ends take off the Controller 68(bring velocity down to 0) (same as a sustain pedal)
    See if that works.
    All I can Say is...HA!...HA!...HAAAAAAA!!!!!

  6. #6

    Re: Adding control event #64 to produce legato

    without fail, the polyphony setting of the instrument (loaded sound) must be no more than one, otherwise this CC64 legato feature will not work.
    I should have mentioned that earlier, sorry

  7. #7

    Re: Adding control event #64 to produce legato

    Thanks for persisting. Pardon my ignorance, but I still have not succeeded in producing legato.

    As StrangeCat suggested, I drew Controller 68 velocity 127 (in Logic I believe this is hyperdraw), but that didn't seem to work (even with control #64). Since I can't seem to attach images in the forum, I've published a screenshot here:

    I should mention that I'm trying to produce legato for a single violin section instrument (Violins 1 KS) in Garritan Personal Orchestra.


    Following up on Dan's suggestion, I did some reading on polyphony -- as I understand it, it's necessary to turn off polyphonic operation (that is, set to monophonic) in order to use legato? I'm not sure how to do this -- is it just a MIDI event for that track? (I'm using Logic 8)

    In the spirit of adventure, I tried the following. I see that controller #126 is monophonic and #127 is polyphonic operation. I added these events to the earlier sequence (alone and together), but they made no difference:

    1 4 1 80 Control 1 126 127 (Turn on monophonic)
    1 4 1 80 Control 1 127 0 (Turn of polyphonic)

    Is this completely the wrong approach?

    For legato, I tried both control #64 and #68. The manual says #68 works in the Notation set (which I'm not using). I'm using the Violin Section.

    Legato with Polyphonic Instrument

    My other question: Will legato work when playing two notes simultaneously on the violin? (In this case, polyphony would need to be on, right?)
    Last edited by dougkramer; 04-28-2008 at 03:40 PM. Reason: Added reference to an earlier replier

  8. #8

    Re: Adding control event #64 to produce legato

    jj, thanks for going to the effort of making a screenshot. I moved cc#64 in Logic to make it clear it begins before overlapping notes. I set the string sample to Max 1 in Kontakt Player. Then I updated the screenshot:

    The settings look remarkably similar to yours, but alas still no legato. I must be doing something wrong at a very basic level.

  9. #9

    Re: Adding control event #64 to produce legato

    thanks for helping Jon,
    the midi cc number must be 64 not 68.

    Also in the kontakt 2 player, I also forgot to tell you to set the
    controller to cc only

    click on the little icon that looks like gears...

    then under the controllers tab, click on the little white box and choose
    cc only

  10. #10

    Re: Adding control event #64 to produce legato

    Doug do you use skype, pm me for my username if you do.
    Otherwise, please post a short MP3 of what you are hearing.

    Your screenshot is showing CC64 starting after the second note.
    The way you have it now, in the top screenshot of your post number 9,

    proper legato sound will only be heard between the
    second and third note,

    third and fourth note and

    fourth and fifth note.


Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts