• Register
  • Help
Results 1 to 8 of 8

Topic: Instruments aren't playing stereo.

  1. #1

    Angry Instruments aren't playing stereo - again!

    When I've been loading instruments in the Kontact 2 player, I've suddenly realised that they're only playing out my left speaker. Moving the pan slider all the way over to the right just made it much quieter - it was still just coming out of the left speaker. In the outputs section, I noticed that there were two channels named 'st. 1' and 'st. 2'. I set the instrument to 'st. 2', and it played from the right-hand speaker, but I don't know how to make the instrument play through both channels, if that is indeed what I need to do?

    All advice would be great, as this is the last thing I really need to solve before I can get my full potential from GPO, and start posting my technically shoddy and uniteresting pieces in the Listening Room.



  2. #2

    Re: Instruments aren't playing stereo.

    Open St. 1's configuration (Config. button below slider) and make sure it is set to Audiochannels: 2 and ch# 01 and ch# 02 are assigned to two different physical outs. Do the same with St. 2 (>> button).

    In the standalone it could be ch# 01 = 1 - Front L/R and ch# 02 = 2 - Front L/R (or some such) for both St. 1 and St. 2 and in the VST it could be ch# 01 = plugin out #1 and ch# 02 = plugin out #2 for St. 1 and ch# 01 = plugin out #3 and ch# 02 = plugin out #4 for St. 2.

  3. #3

    Re: Instruments aren't playing stereo.

    Wow, I must have seemed pretty stupid there. I was almost certain I'd tried that without it working, so I tried it again already wording the 'sorry, it didn't work' reply in my head, but there we go - it works!

    Thanks for your help (again). That's basically everything I need to know now. Yay!


  4. #4

    Re: Instruments aren't playing stereo.

    Sorry about this, but it seems to have stopped working for some reason. St. 1 is only coming out of the left speaker, and st. 2 is only coming out of the right. I've checked to make sure that it was all set up the way that made it work before - here is the channel output configuration for st. 1:

    This worked fine the before now. I can't for the life of me figure out how to get it to work again, or why it even broke in the first place. It may have been something to do with me setting up a keyboard as an input, and then removing it again, as it all stopped working after this.

  5. #5

    Re: Instruments aren't playing stereo.

    Hi Tom,

    I don't think the keyboard is the culprit. What does the pan slider on the instrument look like? If you've got it panned midway-to-hard in either direction you may not get response from the opposite channel.


  6. #6

    Re: Instruments aren't playing stereo.

    Thanks for the speedy response, Reegs.

    Before today, it would work regardless of where the pan slider was - by that I mean the pan slider still functioned normally, so I could move the sound from left to right, but the sound would still come out of both speakers. For testing purposes (getting a feel for an instrument's timbre), I would move the slider to the middle. I've done the same today. With the slider on the left, it comes out of the left speaker, with in the middle, it comes out of the left, and with it on the right, it comes out of the left noticeably quieter. The right hand speaker is silent all the time.

    Well, actually, that last sentence isn't strictly true. Until I got this fixed the first time round, I'd click on one of the keys on the virtual keyboard, and the note on a piano would sound, as well as a note from whichever instrument I had loaded. This piano note did play stero, but the note from the instrument was just on the left speaker. After I got everything working, the piano would not sound at all when I clicked on a key - it was just the instrument I had loaded which played, and in perfect stereo as well. I was rather pleased that the piano had gone, but it's come back now, and is the same as before - the piano note is stereo, but the instrument I'm trying to play with is not. This may or may not help people to work out what's going on.

  7. #7

    Re: Instruments aren't playing stereo.

    I'm guessing: you hear the piano because you are sending MIDI data from KP2 to some external MIDI player, f.ex. Microsoft GS Wavetable SW Synth, because this is ON in File | Audio/MIDI setup | MIDI | Output Interface and Options | Audio Engine | "Send MIDI to outside world" has "GUI keyboard" enabled. I'm not sure about the missing stereo perspective, but maybe your soundcard can't handle input from two different sources (KP2 and the external MIDI player) correctly. With a little luck it will be allright, if you stop the outgoing MIDI stream (set all Output Interfaces to OFF).

  8. #8

    Re: Instruments aren't playing stereo.

    It's working again now. I have a feeling it was the fact that I had Microsoft GS Wavetable SW Synth as an output. By turning it off, the piano stopped. It's also playing stereo now, but I'm not sure whether that was because of me turning off Microsoft GS or becuase I did a system restore to the previous day, undoing whatever it was that I did. I reckon that having the outputs set up in this way was probably the cause of the problem. Anyway - thanks very much for your help!


Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts