• Register
  • Help
Results 1 to 8 of 8

Topic: Logic 5.5.1

Share/Bookmark
  1. #1

    Logic 5.5.1

    besides using Omnisphere in my Cubase 4.5.2, I'm also using Logic 5.5.1 the last working version for Windows XP . I like using this because I can edit faster in it than in CB. When I purchased Omnisphere I didn't realize that they were no longer supporting this last PC version of Logic and took it for granted that Omnisphere would also work in it because I purchased it as an update from Atmosphere. But after some long hard discussions with the support from Spectrasonics LES he finally said that the developer can't do anything about this.

    Of course I'm really dissappointed about this because I've purchased all their programs to and supported them and now when I asked for some some support they just ignore it as what seems to be for them as too much trouble. It seems to me that this is a very small problem which could be solved, but they don't seem to be interested in doing anything about it

    So now maybe someone here might know how to write a script for it. What the problem is Logic 5.5.1 writes a word pad "CFG" when the DLL's are loaded for the VSTs so they can be reloaded. Omnisphere will work in Logic but after it is loaded Logic writes a script in the word pad "CFG" for it but Omnisphere doesn't have any info for the word pad "CFG" consequently, when one closes Logic and opens it again it can't find any info in the word pad script that it's written so Omnisphere doesn't load again. So in order to use Omnisphere again one has to delete the empty word pad "CFG" script and it will load again. One can't use the RMX with Omnisphere because it prevents the RMX from draging and dropping the midis onto the sequencer tracks. Also, if one loads Omnisphere with any other plugins it deletes all the other word pad "CFG" scripts info and upon reloading all the VST's they don't show up because the word pad "CFG" script is blank instead of the stored script info.

    Hope you all have understood Anybody have any ideas if this could be solved?

  2. #2

    Re: Logic 5.5.1

    your best bet will probably be to finally upgrade Logic to its current version
    or if you insist on using a windows PC completely switch over to Cubase.
    To expect a manufacturer to support a host that has been discontinued 6 years ago is pretty unrealistic.
    Did you read the system requirements for running Omnisphere before you bought it?

  3. #3

    Re: Logic 5.5.1

    yeah I know what you mean. It doesn't run on my favourite sequencer Opcode Studio Vision Pro 4.2.2 which hasn't been updated since 1999 or 1998....wht was spectrasonics thinking.
    rsp
    richard sven
    sound sculptist
    ------------------
    Nuendo 4.3 | Intel DP35DP : Intel Quad Core QX 6700 : 4GB RAM | Windows XP Pro SP3 | Lynx Two C | Midisport 2x2 | 2xUAD-1, UAD-2 Quad |

    Cubase 4.5.2 | MacBookPro 2.16 Ghz | 10.6.3 | 2GB | TC Konnekt 8

  4. #4

    Re: Logic 5.5.1

    Quote Originally Posted by Hans Scheffler View Post
    your best bet will probably be to finally upgrade Logic to its current version
    or if you insist on using a windows PC completely switch over to Cubase.
    To expect a manufacturer to support a host that has been discontinued 6 years ago is pretty unrealistic.
    Did you read the system requirements for running Omnisphere before you bought it?
    Hi Hans
    Thanks for answering and your opinion

    > your best bet will probably be to finally upgrade Logic to its current version
    or if you insist on using a windows PC completely switch over to Cubase.

    The fact that PC Logic users got robbed and burned all the way around should tell you that software manufacturers don't care! Why should I buy a Mac and loose all my PC Vsts to support a manufacturer that made us all update and update until nirvana only to be sold out behind our backs!

    > To expect a manufacturer to support a host that has been discontinued 6 years ago is pretty unrealistic.

    I don't think it's unrealistic at all the SPECTRASONICS Vsts are just as old and they supported this last PC version until now. All of their Vsts worked fine. The only thing they say about refering to the system requirements for Omnisphere is that must be 2.4 Vst capable. They don't say anything about what Hosts they have tested.
    http://www.spectrasonics.net/instrum...e-sysreqs.html


    Exactly what 2.4 Vst capable means I don't know, I do know though that every Vst that I've ever purchased works in Logic 5.5.1 and I have every Vst from CB almost all from Native around a hundred or more and everything works!

    Omnisphere also works but like I said it has no CFG info and even erases all of their own Products, RMX, TRILOGY, ATMOSPHERE CFG infos plus all of my other Vsts thus making it too much trouble to use all alone! Besides these facts if I'm updating a working Product that they have supported up until this date then one takes it for granted that it will work. If not it should be stated directly in the system requirements that they have discontinued the support of certain Hosts that they were supporting. For my opinion this is misleading the user, because upon purchasing their Products as well as by the product registration they ask you to list out your system. So one can expect here a certain amount of support and not just a sudden death type of thing and that's it. That's a no go!

    Fact is we are all doing business with each other... Nobody is doing anyone here any favors that we didn't pay for. Omnisphere seems to be a very interesting and useful product but the support should be of major interest for every user in times of trouble and this is for me the part where Spectrasonics has the chance of showing their true colors, for whatever it's worth to them for the future!
    Last edited by southernsandy; 10-10-2008 at 03:04 PM. Reason: mistakes

  5. #5

    Re: Logic 5.5.1

    Since the 2.4 VST standard was established in 2006 its pretty obvious that a host that was discontinued in 2002 is probably not supporting it.
    Wouldnt you agree?

  6. #6

    Re: Logic 5.5.1

    Quote Originally Posted by Hans Scheffler View Post
    Since the 2.4 VST standard was established in 2006 its pretty obvious that a host that was discontinued in 2002 is probably not supporting it.
    Wouldnt you agree?
    Obvious is when the sun goes up or not. But when they support up to this date their past Plugs in Logic then it's only reasonable to believe that their going to continue this policy unless otherwise stated especially with an update. And if Logic didn't support Omnisphere why does it work? For my opinion it's a simple problem they forgot simply to include this word pad script info and nothing else.

    If your're going from this stand point what plugins are you using that are 2.4 Vst Standard and I'll look to see if I have them and if their working in my Logic...
    Last edited by southernsandy; 10-10-2008 at 05:54 PM. Reason: ok

  7. #7

    Re: Logic 5.5.1 + Omnisphere

    I thought I'd post this little bit of useful info for LOGIC 5.5.1 users if any

    So what I did is to put the Omnisphere Vst into the Steinberg plugins and over the Fruity wrapper I can at least use the Omnisphere simultanious with all my other plugins. But Omnisphere still prevents the RMX from dragging and droping any midis onto the Logic tracks if Omnisphere is loaded Fruity in Logic. So one has to first get down any midi tracks onto the Logic sequencer and then load the Omnisphere. What a pain in the But at least the problem of the wrapper has been solved for which I thank you a thousand and one times or even more

    It seems to me that with so much genious the Developer and his support team could have come up with this... But no it had to be
    Monarch
    Super Member

    from the forums over at dv247.com so don't tell me it's because of the 2.4 Vst

    BIG DADDY STUDIO
    bigdaddystudio's SoundClick page

  8. #8

    Re: Logic 5.5.1

    Southernsandy,

    I´m with you, as a Logic 5.5.1 user feel very much the same.
    The original Logic developers sold us PC users back in 2002 and probably got
    more than 20 silver coins...

    However, the old 5.5.1 version is still unbelievable powerful
    and I totally agree with you: even today 98 % of all modern vst`s and romplers work very well with it. I got among others RMX, Trilogy, BFD, Speakerphone, EWQLSO, B4, Kontakt2, Virus, Oxford EQ, URS 1975 etc.

    When the Omnisphere was published I noticed it´s the heavy requirements
    concerning the speed of the computer and the size of the memory.
    One of the biggest basic limitations of the PC Logic is that it can utilize
    only 1 GB RAM. In the case of the Omnisphere only this feature excludes
    us outside the "chosen" - unfortunately. Here´s the line: we just
    have to live without this wondermachine.

    Harry

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •