• Register
  • Help
Results 1 to 8 of 8

Topic: omnisphere update loading problem

  1. #1

    omnisphere update loading problem

    please help me i am a musician and not a computer tech head. i have downloaded the latest updates into omnisphere and the patch browser does not work. it appears that all the new sample names are there but nothing will load. the multi browser works fine. can anyone help me with this issue, thanks for your help, rickjr

  2. #2

    Re: omnisphere update loading problem

    Be sure to check the FAQs at http://support.spectrasonics.net when you encounter a problem with Omnisphere. For example, there is one there entitled "Can't Load Patches After Upgrading to Patch Library 1.0.3?".

    - Glenn

  3. #3

    Re: omnisphere update loading problem

    thanks glenn for responding to my problem. i have loaded all the latest updates from omnisphere and there is still the problem with the patch browser. all the sample names are there but when clicking on one to load it nothing happens . when i first loaded the patch library into omnisphere, an error message comes up and says the program file name is too long, i then hit ignore and it continues to load, so something isnt quite right. what do i do? thanks for any help, rickjr

  4. #4

    Re: omnisphere update loading problem

    I was having the same problem...thought I had installed the 1.0.3 software. I read this post, went back and pulled up Omnisphere and found it was the old version.

    To be sure I had it correct, I re-downloaded and started to re-install, when...I noticed that Spectrasonics defaults the .dll install to the Steinberg\VST folder.

    While I use Sonar, which when prompted, can search and pull up .dll's from anywhere, I typically place all my synth plugin's into the Cakewalk\VST folder (I also use ProTools RTAS). I browsed and re-installed the .dll into my Cakewalk\VST.

    Bang! Omnisphere not only loaded much faster, the new patches all worked, I could now pull up the Atmosphere patches...and the mod wheel suddenly worked smoothly without snaps and shutting down the audio engine.

    Bottom line -- check where your .dll is being installed. This might be what's happening in your case. Good luck.


  5. #5

    Re: omnisphere update loading problem

    I was having the same exact problem with my patches as well. I also use sonar x1. I use the 32 bit on my laptop because although Windows 7 is 64bit, I found the (2 cores) processor could not handle all the tasks. I use 64bit on my desktop which is a quad core.

    Anyways, I found none of the sounds working because the installers had loaded them in the regular program file (64 bit) instead of program files (x86). Now you can take the steam file and just copy it over, but it doesn't register perfectly. So make sure that you check the location of each installation disk. Make sure its going to the STEAM folder in the correct program file location. 32 = program files (x86) 64 = program files.

    This immediately solved my problem. I hope this helps anyone reading!


  6. #6
    New Member
    Join Date
    Oct 2011
    Mumbai, Maharashta, India

    Unhappy Re: omnisphere update loading problem

    Guys plz help me....m in big trouble...
    i recently installed windows 7 64 bit SP1 on my pc...and now i cant use my omnisphere with my any of the DAW's (FL Studio Or Cubase 5)....since ive using windows 7 64 bit (not a SP1 ) and its working well...with no issues....now its not working...
    its showing this

    and after that

  7. #7

    Re: omnisphere update loading problem

    i would say that just try to redownload this version i am sure your problem may get resolved very soon.....

  8. #8

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts