Hi all,

there seems to be a little CPU problem with the waveshaper - at least on my system. With the WS enabled AND one or all of the parameters depth, mix and gain* set to zero, the CPU can go through the roof. The effect is cumulative, i.e. strongest with all set to 0. It happens in synth and sample mode. Tested with default saw patch + WS + full unison, 8 voices - which brings my CPU to its knees. My test set-up:

Q6600, 2.4GHz, XP32, Audiophile 2496, ASIO, 256 samples buffer @44.1kHz - energyXT

This can get important when controlling the waveshaper with MIDI or otherwise, i.e. its depth/mix is set to 0 (clean) and brought up with modwheel or maybe an envelope.

There's also a simple workaround: set those parameters always at least slightly above 0 (smallest increment is enough) - the CPU drop is really drastic! Might be a denormal problem maybe? So, this is mostly a heads-up for users to avoid these settings. Though I'd appreciate it if this could be addressed in a future update - provided it's a general problem and not limited to my system.

Can anyone else confirm?


*) OK, there's no point in setting gain to 0, so that's just for the sake of comprehensiveness and maybe an additional clue. The CPU rise seems also the worst with this one.