• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Topic: Omni: clicks with sample start time offset?

Share/Bookmark
  1. #1

    Omni: clicks with sample start time offset?

    Hi, maybe someone here can be so fantastic and try out what I am facing here:

    - build a simple Patch in Omnisphere with a bell type sound, e.g. the "school mallets" soundsource
    - set the sample start point so some offset so that the very 1st attack is skipped
    - play and record some notes, listen while playing
    - play them back. Listen again.

    I hear clicks at note starts which I do not hear while playing realtime or when recording. I think about every 3rd - fifth note is affected.

    I personally use a Mac with Logic, latest versions. But I also checked with Cubase - same situation. Also tried: different samplerates, different buffer settings, streaming set to "off", several streaming settings. Always similar.

    It would be a big big help if someone could check or tell me something about it. In parallel I also contacted the support, sorry for that double strategy, but I'm somehow nervous as my current project is somehow built on such a sound...

    Best

    Uli
    Uli Reuter
    film composer, Germany

  2. #2

    Re: Omni: clicks with sample start time offset?

    Have you tried to use the different curves for the sample attack?
    The smoother ones shouldnt click.

  3. #3

    Re: Omni: clicks with sample start time offset?

    Uli - Just tried that in Sonar 6 and energyXT 1.4...

    Damn! You're right! Haven't noticed that before. Playback AND offline-rendered audio are affected - clicks all over the place. The slowest start fade doesn't help. I used the "school mallets" and set sample start to 0.115, all else default.

    To make sure I don't get fooled by my own perception, I recorded a repeated note in realtime directly as audio into the sequencer in eXT, switching between the different start fades. Then I recorded the same as MIDI routed to the same instance of Omni. Played both back soloing either the MIDI or the audio. In the audio track there were clicks only with the no-fade setting - as expected. With the MIDI playback, none of the fade modes could prevent the clicks completely.

    Even more strange: When looping a few bars of MIDI, each pass is different. That is, sometimes there are almost no clicks at all, and the next pass it can be a real click-fest.

    It seems the only thing that prevents the clicks, is setting attack to non-zero. However, with the smallest possible non-zero value being 10ms (assuming the readout doesn't lie), this is not an acceptable solution imho. On EDIT: Didn't think of tweaking the envelope in the editor (zoom) in order to get shorter non-zero attack - I'll try that later.

    Thanks for the heads-up, Uli. I must say it's completely beyond me, how there can be a difference between the handling of MIDI coming from a keyboard and MIDI coming from a sequencer track - but there clearly is...


    Quote Originally Posted by Hans Scheffler View Post
    Have you tried to use the different curves for the sample attack?
    The smoother ones shouldnt click.
    They shouldn't, yes, but they do.

    werner

  4. #4

    Re: Omni: clicks with sample start time offset?

    ok Werner thank you...
    maybe the support knows more tomorrow.

    yeah, here I got the impression that 0.01 s as an attack time does work somehow (must still do more tests), but of course it also affects the character of the sound. In fact I would not be surprised at all if 0.00 as attack would cause clicks because of a dc - but the strange inpredictible nature and the absence of click in live playing is strange.

    next question would be if older versions have had that too...

    see you

    Uli
    Uli Reuter
    film composer, Germany

  5. #5

    Re: Omni: clicks with sample start time offset?

    Very strange indeed...

    Just tried fine-tuning attack in the envelope editor fully zoomed in. It's possible to get a nice sharp attack sans the nasty clicks and without altering the sound character too much, even with the sample start at 0 - which could become important when modulating sample start.

    But it's a delicate balancing act and certainly shouldn't be necessary in the first place. Yes, let's hope they have a solution quick.

    werner

  6. #6

    Re: Omni: clicks with sample start time offset?

    cool, at least we have a workaround. we keep in touch

    Uli
    Uli Reuter
    film composer, Germany

  7. #7

    Re: Omni: clicks with sample start time offset?

    No workaround necessary.

    Hans already gave you the correct answer....that's what those three curve swtiches are for. :-)

    See the Ref Guide for more details on how they work. :-)

  8. #8

    Re: Omni: clicks with sample start time offset?

    ok thank you Eric,

    I would somehow be interested though why those clicks are random and why they do not appear when I play live, but that's maybe just because I am a stickler - Anyway everything's fine

    have a nice day!

    uli
    Uli Reuter
    film composer, Germany

  9. #9

    Re: Omni: clicks with sample start time offset?

    It's normal to have clicks when you move the start time, because of zero-crossings on complex stereo sounds in a multisample.....in other words, there's no way that all the zero-crossings could be aligned across all the samples in a soundsource with a single slider.

    Hence the need to modify the attack time via the curve switches or the attack slider if needed.

  10. #10

    Re: Omni: clicks with sample start time offset?

    Hi Eric
    Quote Originally Posted by spectrum View Post
    Hence the need to modify the attack time via the curve switches or the attack slider if needed.
    Maybe I didn't describe clear enough what I did to test. Let me try again:

    The sharp clicks we're talking about do NOT occur with playing live, only on playback and offline-render* - with the exact same settings in Omni. To make sure it wasn't my perception fooling me, I also captured the live audio stream in realtime: again no clicks.

    I do understand what you say about zero-crossings and the fade-in curve switches. But that's definitely not the culprit here. When playing live, such clicks can only be heard with the "no fade in" setting (1st button) - as expected. I could reproduce this with other soundsources in the meantime - sine wave samples lend themselves to testing this.

    Please note also that Uli and I have completely different systems and hosts - yet experience the same behaviour. I'm going to post simple audio examples later.

    werner


    *) it happens also when recording the audio in realtime, IF and ONLY IF the MIDI events driving Omni are sequenced - so maybe here's a hint what's going on there.

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •