• Register
  • Help
Results 1 to 2 of 2

Topic: Invalid challenge from RMX install??

  1. #1

    Invalid challenge from RMX install??

    Hi all

    this is my first post, someone recommended this forum for help with RMX

    i just bought RMX from sweetwater and got it yesterday. i installed the 2 discs fine and went to register it. i hit COPY and pasted it into the RMX account i made. it keeps saying


    i have tried it many times, tried typing it etc but nothing works so i am dead in the water

    i emailed spectrasonics but haven't heard anything. i tried calling them and the lady said someone would call me back.

    just curious if anyone has had this happen and what you need to do to get it fixed??

    thanks for any help

    ps - i am trying to install this on my new MAC Pro, not sure if that matters but its an octo 2.8 on 10.5.6 leopard

  2. #2

    Re: Invalid challenge from RMX install??

    Try the support knowlegebase on the site:


Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts