• Register
  • Help
Results 1 to 6 of 6

Topic: Slightly OT: G-Player and Mac Intel - Help

  1. #1

    Slightly OT: G-Player and Mac Intel - Help

    I'm hoping someone out there in forum-land can help...

    I upgraded to the new Intel Mac a few weeks ago, from my trusty old G5. I've been trying to install the latest version of G-Player (www.soundlib.com) on it. The installation is successful, but Logic won't validate the AU -- it keeps crashing validation. If I try to open it as a standalone, it opens and then immediately crashes.

    I've left voicemail and several support emails for soundlib's tech support over the last 2 weeks, but with no response.

    Has anyone run into a similar problem and perhaps figured out how to make it work? I have a couple composer friends who are using it hassle-free on an identical system, so I'm not sure why my system is having such an issue with it.



  2. #2

    Re: Slightly OT: G-Player and Mac Intel - Help

    That is odd. Usually Bernard gets back in a day or two.

    I'm using it on a MacPro (early2008) OS X 10.5.7 in both Logic 7 & 8 without a problem.

    You should email the crash report for sure and he will figure it out.

    I'm using version both G-Player & Solo V 1.0.6. It's a little odd that the standalone won't open, not sure what the conflict would be with that.

    Your making me wonder if the version matters. I'm going to download V 1.1 and see if that changes anything.

    later that day...

    1.1 works fine. Sorry bro, I would get him the crash report ASAP.
    Stephen Cullo

  3. #3

    Re: Slightly OT: G-Player and Mac Intel - Help

    Hello Mr. Cullo!

    The old version was crashing on my new Intel Mac (1.0.6 I think) so I got the 1.1, and still, the same problem. I even tried deleting all of its components that I could find and reinstalling it, but it still crashes. And the weird thing is, Logic won't rescan the AU folder when I open the AU Manager, so it's still seeing 1.0.6 AU's and not the 1.1 AU's (which is likely the problem). I don't know of a way to force-scan the AU folder for the 1.1 components, but if there is such a thing, that might be the answer.

    I've heard nice things about the guy at Soundlib, so I'm surprised that I haven't heard back... hope tragedy hasn't struck or anything.


  4. #4

    Re: Slightly OT: G-Player and Mac Intel - Help

    Interesting, I trashed only the actual 1.0.6 component (no prefs or anything else) before installing V 1.1, BUT Logic AU manger still says 1.0.6. Even when I "Reset & Rescan Selection" and it tells me:

    validation result: successfully validated

    updating properties of AU G-Solo by Soundlib...done.

    It's still reads that it's version 1.0.6. It's probably one of those recepeit.pkg thing that might need trashing too. Anyway, Bernard if your out there, phone home.

    Oh, and please call me Stephen, Mr. Cullo is my father. lol

    : >
    Stephen Cullo

  5. #5

    Re: Slightly OT: G-Player and Mac Intel - Help

    I think I broke GPlayer.


  6. #6

    Re: Slightly OT: G-Player and Mac Intel - Help

    Problem solved! And Bernard was on vacation, ergo the delay. But his first suggestion fixed my problem.

    The preferences files needed to be deleted:


    and that first one is one that I wasn't aware of/hadn't heard of before. Deleting it did the trick, and a relaunch of G-Player made everything work again. And Logic easily scanned the AU and put it back into my AU window.

    Sigh of relief!

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts