• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Topic: GPO2 with origianl player - update/upgrade options?

Share/Bookmark
  1. #1

    GPO2 with origianl player - update/upgrade options?

    I have the original version of GPO2.

    I'd be grateful if anyone would answer any of the following questions, to help me get up to date.


    Are the following correct? ...

    1) I can download from NI, at no charge, Kontakt Player 2 software that will run GPO2?

    2) After installing the new player, the original GPO2 player can still be run - eg existing Cubase sequences will still open with the old player?

    3) If I upgrade to GPO4, GPO2 will continue to run - eg existing Cubase sequences will still open as before, using either (a) the old player, or (b) the newer Kontakt Player 2 (ie whatever was saved in the Cubase sequence)?


    And, re using GPO with Sibelius 6.1:

    4) Is there a special "Sibelius" version of GPO4?

    5) Does Sibelius's GPO4 "sound set" work with the ordinary GPO4 (that I could upgrade to), or is a special Sib version needed for that? By "work with", I mean will it respond properly to articulations written in the score, etc.

    6) Would the ordinary (not Sib-specific) GPO2 in either the original form or Kontakt Player 2 version work fully with Sib - following score's articulations, etc?

    Thanks.

  2. #2

    Re: GPO2 with origianl player - update/upgrade options?

    Quote Originally Posted by chan View Post
    1) I can download from NI, at no charge, Kontakt Player 2 software that will run GPO2?
    I think so. Didn't GPO2 come with KontaktPlayer2? I also got the Kontakt3 download from NI (demo version, which is the Player version), but I don't use it since it takes a lot more CPU.
    2) After installing the new player, the original GPO2 player can still be run - eg existing Cubase sequences will still open with the old player?
    Are you sure you are talking about GPO2?
    3) If I upgrade to GPO4, GPO2 will continue to run - eg existing Cubase sequences will still open as before, using either (a) the old player, or (b) the newer Kontakt Player 2 (ie whatever was saved in the Cubase sequence)?
    On my system, the old and new version peacefull co-exist, and the sequencer opens the plug-in that you used. It doesn't magically use the new one, so you can continue your projects without any problem.
    4) Is there a special "Sibelius" version of GPO4?
    I think, but I would like to see someone concurs, that GPO4 can be used without problems in Sibelius, but I don't know if you have to do special tricks.
    6) Would the ordinary (not Sib-specific) GPO2 in either the original form or Kontakt Player 2 version work fully with Sib - following score's articulations, etc?
    The GPO versions I have, all have a "notation" set of patches/programs/instruments, which are meant to work in combination with notation programs, and I know a lot of people here use Sibelius. Let's hope they can shed some light...

  3. #3

    Re: GPO2 with origianl player - update/upgrade options?

    Quote Originally Posted by chan View Post
    I have the original version of GPO2.

    I'd be grateful if anyone would answer any of the following questions, to help me get up to date.

    Are the following correct? ...

    1) I can download from NI, at no charge, Kontakt Player 2 software that will run GPO2?
    Hello Chan,

    You don't say which version of KP2 you have. If you have anything less than KP2.2.4 then you should consider updating. As a registered user of GPO2 you should be able to upgrade to the latest version of KP2 at no charge.

    If you have KP2.2 or higher installed then you need only install the player update. Anything less than this then you will need to download and install the KP2 Player and library combination.

    There is, or should be, no extra charge for this.

    Quote Originally Posted by chan View Post

    2) After installing the new player, the original GPO2 player can still be run - eg existing Cubase sequences will still open with the old player?
    Although I don't use Cubase, I use Sonar, this should be correct. If you update to any higher version of KP2 from KP2.2 then all previous KP2 files should open and work just as they did before.

    Quote Originally Posted by chan View Post
    3) If I upgrade to GPO4, GPO2 will continue to run - eg existing Cubase sequences will still open as before, using either (a) the old player, or (b) the newer Kontakt Player 2 (ie whatever was saved in the Cubase sequence)?
    This is a different matter and requires more consideration. Previous versions of GPO which used the Kontakt Player are not really fully compatible with the latest GPO4. This is to say that to use previous files you will need to reassign the instruments and deal with other settings in the new Aria Player.

    However, you can run both the previous KP2 and the new Aria Player side by side. They both co-exist and work very happily side by side. This way you can still play your KP2 files and work on any new projects using GPO4.

    Quote Originally Posted by chan View Post
    And, re using GPO with Sibelius 6.1:

    4) Is there a special "Sibelius" version of GPO4?

    5) Does Sibelius's GPO4 "sound set" work with the ordinary GPO4 (that I could upgrade to), or is a special Sib version needed for that? By "work with", I mean will it respond properly to articulations written in the score, etc.

    6) Would the ordinary (not Sib-specific) GPO2 in either the original form or Kontakt Player 2 version work fully with Sib - following score's articulations, etc?

    Thanks.
    I use Finale 2010 so I am unable to anser your Sibelius questions. However, I do recall seeing an announcement in our forums that the latest version of Sibelius does now support GPO4. Try a search using 'Sibelius GPO4' or 'Sibelius Aria Player' and you should find more info. Here's one example I found;

    http://www.northernsounds.com/forum/...ad.php?t=68939

    Hope this helps and good luck.
    Michael
    Patience is a virtue, sensitivity is a gift

  4. #4

    Re: GPO2 with origianl player - update/upgrade options?

    I've just seen the post written after FLWrd's, which appeared while I was writing this one - I think that probably makes this one superfluous - I'll check and see whether I ought to just delete this.

    Thanks to both of you for taking the time to reply.




    Thanks for the response FLWrd.

    Quote Originally Posted by FLWrd View Post
    Didn't GPO2 come with KontaktPlayer2?
    Re the Kontakt versions ...

    -- My GPO came with "Kontakt Player", not "Kontakt Player 2".
    -- JABB also came with "Kontakt Player".
    -- Stradivari Violin, however, did come with "Kontakt Player 2".


    Quote Originally Posted by FLWrd View Post
    Are you sure you are talking about GPO2??
    I think so. On the box it says "Personal Orchestra Second Edition" (didn't come with Overture). The GPO Library files are dated 13 Oct 03, but the instrument files seem to be dated 2004 & 2005. It was installed on my PC in October 2006.


    I've never been properly clear about Kontakt Player 2 - I thought it was meant to work with different libraries, whereas, with Kontakt Player, there was a separate one supplied for each library.

    My Kontakt Player 2 (Version 2.2.0.005) just shows the Stradivari Violin in the Libraries tab. I always thought there was no way to get it to work with either GPO or JABB, as currently installed - am I wrong about that?


    Quote Originally Posted by FLWrd View Post
    the sequencer opens the plug-in that you used. It doesn't magically use the new one
    I was concerned in case, in order to get my GPO(2) working with Kontakt Player 2, the files (samples, instruments, etc) might have to be re-organised, thereby causing trouble when the old player tried to find stuff.

    I was also concerned in case the program that installed a "GPO-aware" Kontakt Player 2 might delete the original player.



    From what I've read on this forum, I gather that some users aren't happy with the upgrade to GPO4, so I'd prefer not to get that upgrade unless I couldn't get my version of GPO(2) to integrate properly with Sibelius.

    Thanks for reminding me about the "notation" version of GPO - I didn't install that, and I'd forgotten about it.

    However, IIRC, there used to be a version of GPO that was sold (perhaps at a higher price) specifically for use with Sibelius. So I assumed, with my version of GPO, Sibelius wouldn't automatically pick the right samples for the articulations given in scores. But perhaps I'm wrong about that?

    However, I'm getting the impression that Sibelius 6.1's "sound set" for GPO4 is set up to make a non-Sib-specific version work properly with Sibelius.

  5. #5
    Moderator
    Join Date
    Jun 2000
    Location
    Chandler, Arizona
    Posts
    4,045

    Re: GPO2 with origianl player - update/upgrade options?

    GPO2 was still the original Kontakt Player 1.53 version. The Kontakt Player 2 version was GPO3.

    Jim

  6. #6

    Re: GPO2 with origianl player - update/upgrade options?

    Quote Originally Posted by Haydn View Post
    GPO2 was still the original Kontakt Player 1.53 version. The Kontakt Player 2 version was GPO3.
    Ah, I had forgotten that. Then how did we get the license for KontaktPlayer2? I remember I had to create an account at Native Instruments, but surely that is not enough. I cannot find any email about it anymore. The wiki page says:
    Garritan Personal Orchestra must be installed and activated before proceeding with this update. You will also recieve new serial numbers for this update. If you have already performed this update before, you can use the same serial number from your previous run through the update instead of requesting a new serial number. You can locate your previous serial number by clicking Support, Manage Registrations/Activations, and then View Your Registrations.

  7. #7

    Re: GPO2 with origianl player - update/upgrade options?

    Quote Originally Posted by FLWrd View Post
    Ah, I had forgotten that. Then how did we get the license for KontaktPlayer2? I remember I had to create an account at Native Instruments, but surely that is not enough. I cannot find any email about it anymore. The wiki page says:
    Hello FLWrd,

    When upgrading from the old Kontakt Player to KP2, we had to go to our Native Instruments Account page and request a 'new' KP2 Serial Number from there. The new KP2 serial number was then emailed to us.

    The KP2 number request is listed under the 'Garritan Personal Orchestra' download.
    Michael
    Patience is a virtue, sensitivity is a gift

  8. #8

    Re: GPO2 with origianl player - update/upgrade options?

    Thanks Michael. I think it is clear now what chan can do to upgrade: activate an account at Native Instruments, get the license numbers for KontaktPlayer2. You might need to convert your libraries before you can add them to KontaktPlayer2 (which you apparently already have installed for the Stradivarius). You probably also get the opportunity to upgrade to Kontakt3 (but the demo, which can only play existing libraries; it will play new samples for only 30 minutes), but for me Kontakt3 isn't worth it: it sounds the same but takes more CPU.

    As far as we know, installing KontaktPlayer2 won't interfere with existing projects, since it seems you already have them running side by side.

  9. #9

    Re: GPO2 with origianl player - update/upgrade options?

    On the Native Instruments Account Updates page there should be two KP2 updates; one updates the player only, the other updates both the player and the library. This is the case for the older GPO and JABB.

    After installing the full KP2 Player and GPO/JABB libraries, the latest KP2.2.4 can be installed. This updates the player only.
    Michael
    Patience is a virtue, sensitivity is a gift

  10. #10

    Re: GPO2 with origianl player - update/upgrade options?

    Quote Originally Posted by chan View Post

    From what I've read on this forum, I gather that some users aren't happy with the upgrade to GPO4, so I'd prefer not to get that upgrade unless I couldn't get my version of GPO(2) to integrate properly with Sibelius.
    Chan,

    What have you read to discourage you from upgrading to the new GPO4 Aria?

    I have GPO4 and am thrilled with it. I use this with both Finale 2010 and Sonar. There are no issues for me.

    The only things I have read are that some members discovered string tremolo doesn't work. Gary and his team are looking into this and, no doubt, this will be mended. Apart from this, there have been a few discussions on features some members would like to see which not everyone agreed with.

    I have read nothing that would lead me to discourage anyone from upgrading. I would most certainly recommend it; it really is excellent and well worth the small upgrade cost.
    Michael
    Patience is a virtue, sensitivity is a gift

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •