every now and then I'm experiencing problems with Omnisphere arpeggiator.

Sometimes it is completely out of sync with the track, even when I drag a MIDI file from Stylus to Groove Lock, it plays its own way, completely ignoring the BPM of my project. When I'm moving the strength fader it is audible that arp is reacting to it, but it's still not following the speed of the project.
The only way to fix it is to close and restart the whole project.
Sometimes I have to restart the project a couple of times and then all of a sudden it's back in sync again.

Also, sometimes the arp clock gets crazy. For example, I have my arp clock set to 1/16, but when I start to play my arp sequence, it plays much faster, like if it was set to 1/32 or higher. But the clock display still shows the value of 1/16. When I then change it to 1/32 it goes completely nuts and plays the sequence like if it was set to 1/64, if there even was that option...
Again, the only way to fix it is to close the project and reopen it again (sometimes a few reopenings work).

It was happening with the previous versions of Omni/Logic/OSX too, so it is not caused (nor solved) with the latest updates. Also, it does not happen with the same project all the time, but with various different projects with different plugins.

Any suggestions? Anybody having the same issues?


MacBook Pro 2.6 GHz
Mac OSX 10.6.2
Logic Studio 9.0.2
Omnisphere 1.1.3c + everything current versions