• Register
  • Help
Results 1 to 6 of 6

Topic: RMX not showing up in SX 2.2 !!

Share/Bookmark
  1. #1

    Angry RMX not showing up in SX 2.2 !!

    Hi

    I have the last release of Sx2.2 & the latest Stylus RMX (1.9.2d 32 bit).

    It can be loaded into Cubase & plays back from it's own transport.

    But RMX does not show in list of output devices for Midi track in Cubase arrangement !!

    e.g in the dropdown list from Inspector ("Out:").

    It is therefore not available as a Midi track VSTi ...

    Can anyone advise ?


    thanks


    **EDIT** , I think it may be related to this ... http://support.spectrasonics.net/viewtopic.php?t=127

    The video I have says that SX2 or later is needed for drag 'n'drop - but nothing about requiring a VST2.4 host.
    1. E8400 C2D, Asus P5K-E Wifi, , 4GB Corsair 8500 ram, rme MF, sw1000, plugstation, XP SP3, many hosts & plugins

    2. E6600 C2D, Asus P5B Delux, 2 GB Corsair 5700, Audiophile 2496, XP SP3, Emu APS, many hosts & plugins

  2. #2

    Re: RMX not showing up in SX 2.2 !!

    OK, I was right.

    Have installed the last legacy version available from website (1.7.2f) and this works.

    Is this the last version before VST 2.4 came in ?

    If so, what features / bug fixes am I going to miss out on ?

    Can I have more than one version installed at the same time (I have other hosts which are 2.4 compatible) ?


    thanks
    1. E8400 C2D, Asus P5K-E Wifi, , 4GB Corsair 8500 ram, rme MF, sw1000, plugstation, XP SP3, many hosts & plugins

    2. E6600 C2D, Asus P5B Delux, 2 GB Corsair 5700, Audiophile 2496, XP SP3, Emu APS, many hosts & plugins

  3. #3
    Senior Member playz123's Avatar
    Join Date
    Jan 2007
    Location
    Victoria, Canada
    Posts
    535

    Re: RMX not showing up in SX 2.2 !!

    I suspect I'm stating the obvious here, and it's probably something about which you are already aware, but you appear to be using a very old version of Cubase, yet have a more modern, if somewhat antiquated computer, and are attempting to use Spectrasonics software that is currently designed to work with today's technology. It definitely appears it's time to consider a Cubase (and then a computer) upgrade. How old is SX 2.2 actually? It must be at 6-7 years old? I can't recall seeing anyone even mentioning it for years. There are still some SX3 users around, but SX2.2?? The advances in Cubase, including the audio engine , features, VSTi(s) etc. are mind boggling when SX2 and Cubase 5.1.1 are compared. Amazing that you can get anything to work with 2.2 ......................playz
    Cubase 7.0.3, Wavelab 7.1, Omnisphere, Trilian, Stylus RMX, Symphobia 1 & 2 , all Spitfire libraries, LASS 2, Requiem Pro, Voxos, Superior Drummer 2, Komplete 8, Cinematic Guitars, most EW libraries, Chris Hein Horns, Guitar & Bass, 2.8 GHz Mac Pro, 18 GB RAM, OS 10.6.8, RME Multiface II + HDSP PCIe

  4. #4

    Re: RMX not showing up in SX 2.2 !!

    Quote Originally Posted by playz123 View Post
    I suspect I'm stating the obvious here, and it's probably something about which you are already aware, but you appear to be using a very old version of Cubase, yet have a more modern, if somewhat antiquated computer, and are attempting to use Spectrasonics software that is currently designed to work with today's technology. It definitely appears it's time to consider a Cubase (and then a computer) upgrade. How old is SX 2.2 actually? It must be at 6-7 years old? I can't recall seeing anyone even mentioning it for years. There are still some SX3 users around, but SX2.2?? The advances in Cubase, including the audio engine , features, VSTi(s) etc. are mind boggling when SX2 and Cubase 5.1.1 are compared. Amazing that you can get anything to work with 2.2 ......................playz
    Errr.. SX2.2 works fine with RMX 1.7 (and I have other, 2.4 compatible, hosts), along with many other plugins I have (including Komplete 6).

    I'm not going to pay £400 just to upgrade a host that otherwise works fine for my purposes.

    I also take issue with your criticism of my PC - it also works fine (stable & plenty of power for what I need).

    I would like to know, though, at which version number RMX introduced VST 2.4 spec ? I know 1.7.2f works OK with SX2.2 (this is the last "legacy" version available on the website). Is v1.8.x VST 2.3 or 2.4 ?

    If it's 2.3, then I would like to get hold of it for the parameter automation feature introduced at that point.
    1. E8400 C2D, Asus P5K-E Wifi, , 4GB Corsair 8500 ram, rme MF, sw1000, plugstation, XP SP3, many hosts & plugins

    2. E6600 C2D, Asus P5B Delux, 2 GB Corsair 5700, Audiophile 2496, XP SP3, Emu APS, many hosts & plugins

  5. #5
    Senior Member playz123's Avatar
    Join Date
    Jan 2007
    Location
    Victoria, Canada
    Posts
    535

    Re: RMX not showing up in SX 2.2 !!

    Re: "I also take issue with your criticism of my PC - it also works fine (stable & plenty of power for what I need)."
    ---Absolutely no "criticism" intended, mate. It was simply stating the facts that your computer is now back a few years when compared with current 'standards'. You feel it suits your needs, and that's all that really counts. But one certainly can't claim either that it's what can be described as a powerful computer by today's standards. Hope the difference there is clearer?
    LOL, and I'm not laughing at you rather, hopefully, with you (and again no offense intended), you remind me in some ways of an older client we had in the studio awhile ago who felt the same way about things. He'd purchased his computer and software in 2001 for a very large sum of of money, and he said he'd "be damned" if he was "going to buy a new machine and upgrade anytime soon"' because of what he'd spent back then. Not sure, but I think when he couldn't use his dial-up modem with his ISP any longer, he had to do something. Anyway, carry on, ...these sorts of things are definitely up to you, of course...not forum members. My comments were meant simply as a sort of 'heads up' and some suggestions were offered concerning considering an upgrade. Do with them as you wish. Cheers.......playz
    Cubase 7.0.3, Wavelab 7.1, Omnisphere, Trilian, Stylus RMX, Symphobia 1 & 2 , all Spitfire libraries, LASS 2, Requiem Pro, Voxos, Superior Drummer 2, Komplete 8, Cinematic Guitars, most EW libraries, Chris Hein Horns, Guitar & Bass, 2.8 GHz Mac Pro, 18 GB RAM, OS 10.6.8, RME Multiface II + HDSP PCIe

  6. #6

    Re: RMX not showing up in SX 2.2 !!

    I did change my sig to reflect the fact that I'm not a complete luddite (.. got rid of the P4 a while back) ...

    I'd still argue that an E6600 & 8400 are not THAT underpowered, even nowadays. These boards will take Quad cores (including new "S" cooler 65w versions, which I'm seriously considering upgrading to).

    However, I'm certainly not going to spend £400 upgrading a Cubase that works fine for me just so I can use the latest RMX (you would concede that's not unreasonable ? ).

    I've tried renaming an older RMX.dll (1.7.2f) in the VST folder, and it seems to co-exist happily with 1.9 version.

    So that way I can use the old one for SX2.2 and uptodate version for 2.4 hosts.

    swayzak
    1. E8400 C2D, Asus P5K-E Wifi, , 4GB Corsair 8500 ram, rme MF, sw1000, plugstation, XP SP3, many hosts & plugins

    2. E6600 C2D, Asus P5B Delux, 2 GB Corsair 5700, Audiophile 2496, XP SP3, Emu APS, many hosts & plugins

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •