• Register
  • Help
Results 1 to 4 of 4

Topic: Will Trillian work with old Cubase VST 5.1R1?

Share/Bookmark
  1. #1

    Will Trillian work with old Cubase VST 5.1R1?

    Question to developers: Will Trillian work with old Cubase VST 5.1R1??
    Or may be somebody already tried that?

  2. #2

    Re: Will Trillian work with old Cubase VST 5.1R1?

    No, it won't. Trilian needs a VST 2.4 capable host, you have to upgrade to at least Cubase 4.

  3. #3

    Re: Will Trillian work with old Cubase VST 5.1R1?

    I was able to load it with Cubase SX 3 too, altough I'll never used it for an entire project (I recently switched to Cubase 5)

  4. #4
    Senior Member
    Join Date
    Jul 2007
    Location
    Stoke on Trent, UK
    Posts
    194

    Re: Will Trillian work with old Cubase VST 5.1R1?

    I asked the same question when Omnisphere was released.
    Omni, and I assume Trilian WILL load into VST32/5.1R1 but you miss out on a lot of the features. I'm trying to remember, but I think loading all 8 parts, automation within Cubase etc are problematic.
    It was a big decision for me, being so comfortable with VST32/5.1 but in the end I changed to 4.5 (on offer before 5 came out).
    At the same time East West choirs was on offer so I couldn't resist upgrading.

    If I were you, I'd consider upgrading and see if you can get a good deal with big discounts by buying a Cubase upgrade, Trilian etc. There are really good deals out there in the current financial climate.
    Neil B
    Pentium 4 PC Windows XP Home 32 bit 3.6 Ghz, Omnisphere, Stylus RMX, Trilian, Kontakt 3, GPO 3, EWQLSC, Scope Pulsar II, Cubase 4.5

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •