• Register
  • Help
Results 1 to 4 of 4

Topic: Can only use 1 MIDI channel at a time (Ableton/Pro Tools)

Share/Bookmark
  1. #1

    Can only use 1 MIDI channel at a time (Ableton/Pro Tools)

    Hi,
    I'm running GPO4, Kontakt edition, on an XP dual-core PC. I want to use 2 instruments at a time. I want to hear GPO's awesome cello sound and trombone patch playing some harmonies.
    I open up Ableon, and I can set up and hear the trombone with no problems through Channel 1. Sounds great.
    Next, I make another track and load another instance of GPO, this time selecting the cello and setting the MIDI output to channel 2. It loads, and when I play my keyboard, the indicator bar in the lower right hand side of GPO displays MIDI signal coming out. But Ableton (and Pro Tools) doesn't recognize any MIDI input on Channel 2. So I hear no cello. So sad.
    I have also tried loading both instruments into a single player, to no avail. Channel 2 still doesn't get any input or sound, no matter how I configure the player and my Audio program.
    BTW the setup button disappears when GPO is used as a plug-in (both as VST or RTAS). Any way to get it back?
    Thanks for a great library, GG. You have truly rendered a service to the musical community.

    Billy

  2. #2

    Re: Can only use 1 MIDI channel at a time (Ableton/Pro Tools)

    Quote Originally Posted by bongomonkey View Post
    Hi,
    I'm running GPO4, Kontakt edition, on an XP dual-core PC. I want to use 2 instruments at a time. I want to hear GPO's awesome cello sound and trombone patch playing some harmonies.
    I open up Ableon, and I can set up and hear the trombone with no problems through Channel 1. Sounds great.
    Next, I make another track and load another instance of GPO, this time selecting the cello and setting the MIDI output to channel 2. It loads, and when I play my keyboard, the indicator bar in the lower right hand side of GPO displays MIDI signal coming out. But Ableton (and Pro Tools) doesn't recognize any MIDI input on Channel 2. So I hear no cello. So sad.
    I have also tried loading both instruments into a single player, to no avail. Channel 2 still doesn't get any input or sound, no matter how I configure the player and my Audio program.
    BTW the setup button disappears when GPO is used as a plug-in (both as VST or RTAS). Any way to get it back?
    Thanks for a great library, GG. You have truly rendered a service to the musical community.

    Billy
    Hi Billy,

    While I can't tell everything about the configuration of you system from your description the first thing I'd check is the MIDI channel your keyboard is sending. Changing the MIDI channel assignment of an ARIA instrument slot just affects which incoming MIDI channel the slot will respond to. You still need to make sure that the arriving data is on that MIDI channel or you won't trigger the corresponding instrument. Often (depending on the features of the host software) that means changing the MIDI channel output setting on the keyboard itself.

    One other thing: While you certainly can open a new instance for each instrument, that isn't the most efficient way to work. I'd suggest filling most (or all) of the 16 slots in an instance of ARIA before loading another. You can assign MIDI channels and outputs as needed for each instrument in each instance.

    Tom

  3. #3

    Re: Can only use 1 MIDI channel at a time (Ableton/Pro Tools)

    I didn't figure out exactly how you've set up your things, you spoke of midi OUT...?

    But it should work on Live like this: you add two tracks, add a Kontakt Player to both of them and load the cello to the one and trombone to the other. Set the inputs to your keyboard on those tracks, channels 1 and 2 correspondingly. Then make sure you've armed both tracks. If you can only set rec to one of the tracks at the time, then you need to hold down a modifier (can't remember which... CONTROL, COMMAND, ALT, ALT GR...?) when you enable the rec on those channels so the other won't get dearmed.

    If these posts won't help you, maybe you can mail me you ALS-file? You can find my email from the website on my signature.
    Film Composer - www.juhanalehtiniemi.com
    My latest project: Our first indie pop -single, produced in Ableton Live, available also on iTunes and Amazon
    Mac Pro 6-core 3.33GHz

  4. #4

    Re: Can only use 1 MIDI channel at a time (Ableton/Pro Tools)

    I think the problem you're having, bongo, is a basic misunderstanding of how to set up MIDI projects not just in Live, but in any recording app - because they all do things in pretty much the same way.

    Tom's post explains a lot. To re-phrase so you can hear it again: Each MIDI track in your project is set to a different MIDI channel. The easiest way to have your controlling keyboard able to communicate separately with each track is to set it to OMNI, so all MIDI channels are being sent out. But each tracks filters all MIDI channels out except the one they're set to.

    karvasika said:

    "... you add two tracks, add a Kontakt Player to both of them..."

    This isn't necessary, and is the other thing Tom's post referred to. We're often seeing people inserting multiple instances of sample players when they don't need to. It's a waste of CPU power. Kontakt can hold 16 instruments, each on a separate MIDI channel when set up properly. There's no need to insert a new instance until you've gone beyond using 16 instruments in a project.

    Mabe "Live" requires all these separate instances, but I can't imagine that--it would be a primitive way to have a recording program designed, but Live is a major loop-oriented music machine.

    Randy

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •