• Register
  • Help
Results 1 to 7 of 7

Topic: Unsupported format issue

Share/Bookmark
  1. #1

    Angry Unsupported format issue

    This morning I discovered an issue in Kontakt. It was while I was using NineVoltAudio's TAIKO library, but I suspect it might be a more fundamental issue, if I were to poke around all my libraries, so I thought I'd post here and see if anyone has encountered it.

    I've had TAIKO for ages, but never really used it till now. I did at least open a stack of patches and try them out, when I bought it, at which point I was in Kontakt 2 on an XP machine. Back then everything worked fine.

    This morning I tried opening some patches in Kontakt 4, on a Windows7 machine laptop, and many refused to open. I got an error message saying 'unsupported format' which didn't say whether it was referring to the nki file or the samples themselves. So I tried to load the same patches in Kontakt 3.5, on a WinXP laptop; there the patches loaded without any error message, but didn't load any samples at all.

    My first guess is that some of the samples are at a bitdepth or sample rate not supported on my laptops (which are both using the onboard soundchip and ASIO4All driver), but many patches still load absolutely fine, and I can't imagine that the samples are at several different rates. Nor can I imagine, if that were the problem, why Kontakt 3 wouldn't complain about it, as opposed to simply ignoring the samples.

    I can't even tell which wav files I need to investigate, since neither version of Kontakt is actually getting as far as having any samples loaded.

    Has anyone had any similar issues in moving libraries to more recent versions of Kontakt?
    David

  2. #2

    Re: Unsupported format issue

    Hello Pingu,

    (Please excuse my weak english)

    I have the very same problem on Mac OS X (Kontakt 4.1).
    I don't recall the name of the patches having this problem but they were all from the "same family". I'll check and report later to see if we have this problems on the very same patches.

    My intentions were to unrar the archives downloaded 2 years ago when I bought Taiko to check if it was not a data corruption on my disk then to write to Nine Volt Audio, Kyle is very nice and certainly would help us :-)

    I'll keep in touch,

    Alex.

  3. #3

    Re: Unsupported format issue

    Hey Pingu and Alex

    Yes I can confirm that something is wrong - though I'm not sure it is a Kontakt problem.

    I've just been a little investigating, and it seem the problem is the Update .rar from 09-04-2009. All the new samples is wrong!!
    Try to look in the Folder called "New Samples", as you can see all the files are unknown.

    So this is why Kontakt can't read the samples.
    This happens on all the new Presets from 2009 starting with 2d - and 2m -.

    So if you try to load these presets in Kontakt 2, at first it seem that it work here - but this is not true. Ofcause Kontakt 2 can not read the unknown files.

    But Kontakt 2 is not as clever as Kontakt 3/4, so it's fooled by a MAJOR naming mistake in this library. All the samples in the different subfolders, are named the same!!! (1 - 2 - 3 - 4 ---)

    This is very very very bad, cause if Kontakt is searching for a sample, it thinks "well here's my "2" sample" but maybe this "2" sample belongs to an other folder/articulation.

    So what happens is that Kontakt 2 loads the samples that has the right name, but is from the wrong folder/articulation.

    The naming thing is not Kyles mistake - this is back from Tsaiko who made this library first.

    So yes - we need to contact Kyle

    Best regards
    Bo

  4. #4

    Re: Unsupported format issue

    I just wrote to info at Nine Volts Audio...
    Let's wait and see for a few days.

    Cheers,

    Alex.

  5. #5

    Re: Unsupported format issue

    Quote Originally Posted by Bo Clausen View Post
    Hey Pingu and Alex

    Yes I can confirm that something is wrong - though I'm not sure it is a Kontakt problem.

    I've just been a little investigating, and it seem the problem is the Update .rar from 09-04-2009. All the new samples is wrong!!
    Try to look in the Folder called "New Samples", as you can see all the files are unknown.
    Thanks Bo,
    I eventually discovered the same thing. I'm no expert on file protocols, but I'm guessing some kind of 'file header,' that would tell windows what type of file it is, must be missing, because the wav data was actually intact, and the files could still be opened in Sound Forge. I simply opened all of them and resaved them as .wav.

    For some reason, even though I resaved the samples with their original names into their original folders, the .nki wouldn't see them. I couldn't even use the 'browse for folder' option - I had to point each preset at every one of its samples. It took a long time, but everything works now, and has been backed up several times over.

    I can't imagine this issue went completely unnoticed for the last year - it may turn out there's already an official update that I didn't know about. If not, though, I'll quite happily share the new nki and nkm files if that's ok with Kyle.
    David

  6. #6

    Re: Unsupported format issue

    Quote Originally Posted by Pingu View Post
    it may turn out there's already an official update that I didn't know about.
    Hello All,

    Sorry for the frustration! The last thing I want is for someone to have to spend their time trouble shooting one of our products.

    Yes, there is an update that corrected issues with these patches:
    (your version may or may not have the number "2" on the front of the patch name)



    As I recall, for some reason, the ".wav" portion of each sample got removed (by Kontakt!) from the new patches that we offered - and at the time, they worked fine in K2, but not K3 - so we created monolith file versions of these patches, which corrected the issue.

    Just drop me an email at info@ninevoltaudio.com and I'll get you directed to the proper update. If there are issues with any patches not listed above, please let me know and I'll investigate ASAP.

    I just did a random test of around 25 TAIKO patches in K4 and they loaded without issue.

    Thanks!
    Kyle
    www.NineVoltAudio.com
    info@NineVoltAudio.com
    Loop libraries designed for users of Stylus RMX, Reason and other REX format players

  7. #7

    Re: Unsupported format issue

    Thank you very much :-)

    Don't be sorry, it happens sometimes.
    I am very pleased by your nice support, it is - beside the quality of your products - the best advertisement for your company and I appreciate that very much.

    Cheers,

    Alex.

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •