• Register
  • Help
Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Topic: Omnisphere 1.5 problems with Key Select Mode in Live mode

Share/Bookmark
  1. #1

    Omnisphere 1.5 problems with Key Select Mode in Live mode

    Hi,

    I have some trouble in Omnisphere with the Key Select mode in Live Mode since the 1.5 upgrade.

    When using CC mode and Key Select mode together the CC mode selection supersedes the Key Select settings.

    Other strange thing: if I select touch mode in both CC and Key Select mode then I can't select anymore multiple parts with the Key Select (it worked fine in 1.3).

    If I learn only the Key Select notes then the touch mode works normally until I select a part with the mouse. In this case the part selections freeze.

    The CC mode works normally (also with the mouse select).

    Sorry for my poor English !

    Any idea ?

    Thanks

  2. #2

    Re: Omnisphere 1.5 problems with Key Select Mode in Live mode

    Hi Phil777

    I am a long time owner of Omnisphere and have experienced very similar to what you describe.

    Hhave found even in previous version of Omnisphere that key select touch mode does not work in live mode until the omnisphere interface is displayed. E.g. in Brainspawn Forte you need to 'drop down' select the initial omnisphere splash screen once before it will work. Then is does work OK.

    But obviously 'nerding around' with the mouse when using a live host - and for every instance (and Trilian is the same) is not 'cool' - and should not be neccessary - makes it very difficult to use.

    However in 1.5 its now even worse!

    The spectrasonics training video says that CC and key select modes are not mutually exclusive - but after the 1.5 update I now experience the midi learn map actually changing prior learns (E.g. making them toggles as if having been learnt in switch mode) . This happens if any mouse selection of a part is performed in live mode.

    It obviously makes it useless i.e. unuseable

    I first reported the aforementioned problem (i.e. before 1.5) to Spectrasonics back in Dec 2010 but although they have passed it to their developers, I am dissapointed that the product is for me - totally unuseable in any live situation.

    I don't think - from my tests, that it has any relevance in terms of the serious problem now with 1.5

    But what host do you use?

    Miles

  3. #3

    Re: Omnisphere 1.5 problems with Key Select Mode in Live mode

    Hi Miles001,

    My host is Ableton Live Lite 8 release 8.2.1. But I can reproduce exactly the same problem with GarageBand.

    Thanks for your Help

    Regards,
    phil777

  4. #4

    Re: Omnisphere 1.5 problems with Key Select Mode in Live mode

    Quote Originally Posted by Phil777 View Post
    If I learn only the Key Select notes then the touch mode works normally until I select a part with the mouse. In this case the part selections freeze.
    That is fixed in the next update.

    When using CC mode and Key Select mode together the CC mode selection supersedes the Key Select settings.
    There does indeed seem to be a problem using key select and midi CC simultaneously. We'll investigate that.

    Quote Originally Posted by Miles001 View Post
    have found even in previous version of Omnisphere that key select touch mode does not work in live mode until the omnisphere interface is displayed. E.g. in Brainspawn Forte you need to 'drop down' select the initial omnisphere splash screen once before it will work. Then is does work OK.
    I'm not familiar with Brainspawn Forte, but that works fine in a variety of other hosts we've tested.
    Glenn O
    Spectrasonics

  5. #5

    Re: Omnisphere 1.5 problems with Key Select Mode in Live mode

    On my system (Windows 7 64-bit, Cubase 6 32-bit) the touch mode of the key select function is unusable since 1.5. Parts are activated/deactivated by random i.e. if I continue to press the same keys simultaneously the activation state of the corresponding parts sometimes changes and sometimes not. This erratic behavior does also happen if CC mode etc. is deactivated. Latch and switch mode seem to work fine anyhow.

    Regards,
    Stephan

  6. #6

    Re: Omnisphere 1.5 problems with Key Select Mode in Live mode

    Key select in touch mode works fine here with 1.5 and we haven't had any other reports of a problem with that, with the exception that simultaneously assigning CC's will interfere. Key select in touch mode is the most common way live mode is used, so that has been tested and used extensively and I'm quite confident that's working fine. If you're saying you're having problems when you have no CC's assigned to the parts, you should contact tech support (support.spectrasonics.net) for assistance.

    Quote Originally Posted by stanft View Post
    On my system (Windows 7 64-bit, Cubase 6 32-bit) the touch mode of the key select function is unusable since 1.5. Parts are activated/deactivated by random i.e. if I continue to press the same keys simultaneously the activation state of the corresponding parts sometimes changes and sometimes not. This erratic behavior does also happen if CC mode etc. is deactivated. Latch and switch mode seem to work fine anyhow.
    Glenn O
    Spectrasonics

  7. #7

    Re: Omnisphere 1.5 problems with Key Select Mode in Live mode

    I have made some further investigations. The problem with key select touch mode seems to be related to template loading.

    One example:
    - Load a new multi in Omnisphere
    - Go to multi / live mode and activate live mode
    - Step through the different parts by clicking the next button and learn a note assignment
    - If finished, the key select touch mode works absolutely fine.

    - Now I save the template and create a new Omnisphere instance.
    - I load a multi, go to the multi mode, activate the live mode and load the template I have saved before.
    - Now, the key select touch mode behaves weird on my system.

    - Similar strange things happen as soon as a part is selected by clicking with the mouse. From now on, the touch mode behaves weird, too.

    The only way to fix the weird behavior is to reassign the notes again.

    I have experienced this behaviour in Cubase 6 as well as in Reaper 3 so it seems that this is not host-related.

    Regards,
    Stephan

  8. #8

    Re: Omnisphere 1.5 problems with Key Select Mode in Live mode

    Quote Originally Posted by GlennO View Post
    That is fixed in the next update.


    There does indeed seem to be a problem using key select and midi CC simultaneously. We'll investigate that.
    I'm having trouble with the key select feature in live mode as well. Any thing I can do until your next update?

  9. #9

    Re: Omnisphere 1.5 problems with Key Select Mode in Live mode

    Quote Originally Posted by stanft View Post
    I have made some further investigations. The problem with key select touch mode seems to be related to template loading.

    One example:
    - Load a new multi in Omnisphere
    - Go to multi / live mode and activate live mode
    - Step through the different parts by clicking the next button and learn a note assignment
    - If finished, the key select touch mode works absolutely fine.

    - Now I save the template and create a new Omnisphere instance.
    - I load a multi, go to the multi mode, activate the live mode and load the template I have saved before.
    - Now, the key select touch mode behaves weird on my system.

    - Similar strange things happen as soon as a part is selected by clicking with the mouse. From now on, the touch mode behaves weird, too.

    The only way to fix the weird behavior is to reassign the notes again.

    I have experienced this behaviour in Cubase 6 as well as in Reaper 3 so it seems that this is not host-related.

    Regards,
    Stephan
    When you go through that routine, does the live mode operate normally? For me, the parts keep on piling up, instead of switching from patch to patch.

  10. #10

    Re: Omnisphere 1.5 problems with Key Select Mode in Live mode

    Quote Originally Posted by GlennO View Post
    Key select in touch mode works fine here with 1.5 and we haven't had any other reports of a problem with that, with the exception that simultaneously assigning CC's will interfere. Key select in touch mode is the most common way live mode is used, so that has been tested and used extensively and I'm quite confident that's working fine. If you're saying you're having problems when you have no CC's assigned to the parts, you should contact tech support (support.spectrasonics.net) for assistance.
    There are definitely problems. I have a number of multis, with no CC's assigned, and the key select is pooched. I select one, then another, and they are both selected. They continue to pile up, and you cannot deselect them using your assigned keys. Tested on two computers, with different kbd controllers. I did contact tech support, but in the meantime, the rehearsal is over.

    Pat

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •