• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Topic: RMX Memory use increases with multi/part clear

Share/Bookmark
  1. #1

    RMX Memory use increases with multi/part clear

    Being a very late convert to RMX, I'm still encountering odd things. This one is as per the title really. As I load different groove multis, or even elements, the memory usage increases constantly, irrespective of the size of the groove, and at no point do I see the memory reduce. Even when I select clear part or clear multi, instead of releasing the memory, it shows it as increasing by nearly the size of the groove I am clearing! Huh? So within a few different multi loads, my memory is through the roof. After loading a few different multis and then selecting 'multi clear', I will have just the 'sound check' selected in the mixer, yet I can be showing 400MB or so in the memory usage in the parameter window.

    It must be something silly I'm doing (or not) I know, but I just can't figure it out. Any ideas most welcome!

    1.9.5d 32 bit, XP SP3 and 3GB RAM w /3GB switch and Cubase 5.5.3

    Thanks.

  2. #2

    Re: RMX Memory use increases with multi/part clear

    Just a gentle bumb really. If nobody has an explanation or solution, can you just confirm that when you guys select 'clear part/multi' the memory meter drops? Then I can just rattle off a support email to Spectasonics. I guess I just need to know I'm not missing something obvious really.

    Thanks.

  3. #3

    Re: RMX Memory use increases with multi/part clear

    Could be that your increasing memory problem has to do with you running XP. RMX of late requires Win7/Vista to run at its best.

    I can confirm one part of your complaint, though: Clear Part/Multi does not release memory, but it doesn't increase it, either.

  4. #4

    Re: RMX Memory use increases with multi/part clear

    Thanks for responding. WHat you found with memory not dropping is what I had before I reinstalled my system. The only way the memory would drop for me was by clearing, and then selecting a new part/multi. The memory would then show the new memory value. But no, I can confurm that now, when I clear it does certainly go up. Most confusing....

  5. #5

    Re: RMX Memory use increases with multi/part clear

    You say you reinstalled your system. You reinstalled XP then? The only way to go now is Win7 64 XP is slowly dying. More and more manufacturers of VST:s and DAW:s don't support XP anymore.

    I'm running Cubase 6 32 under Win7 64, that's the recommended thing as I'm still dependant of some 32bit plug-ins, mainly UAD. The internal Cubase 64bit bridge is not an option for serious work, it adds too much CPU overhead and you lose functionality. I'm not buying anything new that hasn't got an announced 64bit path, present or announced. As soon as UAD gois 64bit, I'm switching to Cubase 6 64.

  6. #6

    Re: RMX Memory use increases with multi/part clear

    I hear what you say about XP and 32bit. Win 7 and 64 bit is coming soon!

    Would you (or anyone) be kind enough to try something for me though? My memory issues are hit and miss when I try to 'part clear'. But everytime I clear a multi, that will always increase the memory. Have you tried it with Multi clear? If not, I would appreciate someone trying this for me. Thanks.

  7. #7

    Re: RMX Memory use increases with multi/part clear

    I've tried both Multi Clear and Part Clear. None of them clears the RMX memory, but nothing is added either.

  8. #8

    Re: RMX Memory use increases with multi/part clear

    curious- does this affect the performance? Are you sure that the system is just not releasing it until new stuff is ready to load in and take its place. I imagine this is likely by design- no need to flush memory when it is ready to be written over. Something to consider.

  9. #9

    Re: RMX Memory use increases with multi/part clear

    Thanks BBB. And yeah javaj, it is odd. I can imagine that the memory is released and available, yet still show as taken. But it's the way it actually shows as increasing when I multi clear that confuses the hell out of me. I've rattled off an email to support. So I'll see what they say. There are no performance issues as yet, but I've not pushed it. I will try that next though. I'll keep loading big multis until the memory gets to the point that it should crash. Will let you know....

  10. #10

    Re: RMX Memory use increases with multi/part clear

    Quote Originally Posted by Javaj View Post
    curious- does this affect the performance? Are you sure that the system is just not releasing it until new stuff is ready to load in and take its place. I imagine this is likely by design- no need to flush memory when it is ready to be written over. Something to consider.
    This is exactly what happens here. Load a multi, maybe you've gott 100MB used. Load another, now maybe you've got 90, or 110, depending on the size of the multi. But Clear Part/Multi does not release the memory, like you think it should.

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •