• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Topic: odd GigaStudio160 behavior

Share/Bookmark
  1. #1

    odd GigaStudio160 behavior

    I\'ve just upgraded (both software and hardware) to the GigaStudio 160.
    It is an AMAZING system....if it would work....

    After al the PC tunings (except for the Explorer.exe and FAT16 ones) I got the GigaHarp instrument playing over a 152 polyphony with NO glitch/cliks at all!

    Now the wierd part: when I start to add NFXs, (beginning from the second one, or even from the first one turned on) bad glitches occures!! It is like the sync is lost between the GSt and sound card or so...
    And the clicks/glitches are produced even if there is no notes played.
    But again, before turning on the NFXs (one or two!) the behavior is superb.


    My system:
    P3-700MHz, 192MB ram, MinMAxVCache=0 (I tried with 2k, 4, 8k), AGP video, dedicated 7200 MAXTOR drive, WaveCenter/PCI soundcard feeding an EMU APS SPDIF input (on a separate PC).
    Buffer size (WaveCenter)=256 samples.

    At the beginning I had clicks right away (even without FXs), but especially after bringing the master attenuation down to -10dB or so, there are all gone.
    So it is not a hard drive problem, nor a sync issue with the other sound card.

    Did anyone have the same problem?

    mihmar

  2. #2

    Re: odd GigaStudio160 behavior

    Mihmar,
    The post below is from Charles (cc).
    I thought it more to direct to just paste it here than tell you to go scout.
    It concerns changing the size of your Vcache.
    You never know.....


    There are many different variables that affect polyphony - but as to vcache I suspect the following will hold true:

    The more instruments you play simultaneously, the more splits in a particular instrument,
    or the longer the underlying samples, the less a particular vcache setting will help.

    Also, if you play many different notes without repetition (e.g. C3 D3 E3 F3 ...), I think vcache will help you less than playing repetitive patterns like C3 D3 E3 C3 D3 E3.

    Its all just a matter of what can fit into the available vcache area and how long it can
    stay there. Some data are inherently more cacheable than others, so it also depends on
    the individual instrument.

    I would think in Danny\'s case, doubling vcache should show some difference. (Note: see below, this may cause trouble elsewhere). Of course there are other factors determining
    polyphony, like soundcard drivers, motherboard, hard drive, drive controllers, etc.

    In my experience, certain systems will give less polyphony than expected (i.e. when you
    get 90 voices on an 800Mhz machine), because of suboptimal performance of the hard drive controllers (even if all drives are on separate channels). Sometimes using a plug- in SCSI or IDE card is also not a good idea, since it seems they can add significantly to the effective access/seek time. (I have seen 33ms thru such a card to a 9ms drive!).

    In these cases, increased vcache may show significant performance increases, because
    it is counteracting a problem that crept in somewhere else.

    It also seems to me that timing is an issue: if you are triggering multiple instrument notes at exactly the same time, chances are you will strike a lower polyphony limit (at least in my system).

    Increasing vcache basically attempts to buffer as much of your instruments in RAM as
    possible, which is like going back to the RAM-based sampler...

    Just a note: increasing vcache also steals ram from Giga, which means fewer available
    instrument \"slots.\" I.e., it seems that if you assign 25% of ram to vcache, you can only
    safely load instruments until the GSt memory indicator hits 75% - or face a crash.

    [This message has been edited by cc (edited 07-05-2000).]



  3. #3

    Re: odd GigaStudio160 behavior

    Mihmar, following the advice of others, set your vchache to 25% of your ram, i.e. in your case 49152. (remember that you can only then load instruments until GSt\'s memory indicator hits 75%)

    Other than that, make sure your dedicated drive is on its own IDE channel (i.e. not a master/slave connector). It seems better to use your motherboard ide for this drive, rahter than a plug-in card.

    Also check that your IDE controller is not sharing an interrupt with anything else, especially not with your AGP card. It is also better if the soundcard doesn\'t share interrupts.

    Let me say straight out that I do not own a wavecenter, but if the above does not help, I may try doubling the wavecenter buffer size. 256 samples only equate to 2.5ms of stereo sound.

    // Charl

  4. #4

    Re: odd GigaStudio160 behavior

    thanks to you all for the answers.

    The MinMaxVCache=0 works the best to me. The polyphony is at least 158 - more than I need, so it\'s OK. My IDE/PCI chains are also OK, since I get this kind of polyphony with no glitches.

    But again, when I activate a FX or two ... BOOM! Bad/loud glitches are produced once at (I think) 20..30 seconds, even if no notes are played.
    I set the master attenuation to -15dB.

    please help...I am so close, but still the most exciting (to me) side of the GSt is not working well - the DSP!!!

    mihmar


  5. #5
    Senior Member LHong's Avatar
    Join Date
    May 2000
    Location
    San Jose, Ca, USA
    Posts
    542

    Re: odd GigaStudio160 behavior

    Mihmar,
    I have some suggestion about your setup, just simply ignore it if you see that might not works for you. See the following:
    1> I don\'t know what\'s right or wrong. Try set the Vcache= 192x256 (about 49152, so far I see about 8k=8000). Let\'s say the Vcache doesn\'t help about your polyphony, how about improving the sound quality...even you get 180 voices, so what? first thing, you need the sound quality (no pop or cracle) then start to think about to fine-tune for the max. of voices. (CC has explained it very logical, thanks CC).
    \"At the beginning I had clicks right away (even without FXs), but especially after bringing the master attenuation down to -10dB or so, there are all gone.
    So it is not a hard drive problem, nor a sync issue with the other sound card.\"
    You decreased the amplitude of course the Giga will produces the sound resolution, It doesn\'t mean anything about synchronization. It seems be Vcache too low or you need more DRAM in your system (256MB is good size to start).
    About \"the master attenuation to -15dB\", it is too low for a digital signal. the good ranges about -3db to +3db, you will loose the dynamic bandwidth or adding noise to it if your recoder boot it to 0db (good level quality to record a digital signal). So never set the master attenuation below -6db.
    2> From your setup, it seems that you have to run two PCs for this (it might not relative problem that you have now, but it will)
    Honestly, I don\'t feel this is a good solution for Giga\'s enviroments. In any cases, you will have an extremely synchronization problem + douplex latency, due having difference time-base between the two soundcards of two PCs. You can try some experiments, you will tell the audio tracks in your sequencer that you\'ve never got perfectly sync.(when you record or capture different time). I don\'t know what audio quality you looking for but when you do the final-mixdown, you will have all kind of problems (noise, sound degration, distortion, etc) because of that.
    Well, if you really want to interface between two PCs in perfect sync. you should have a SMPTE/MTC protocol (chasing clock). \"WaveCenter/PCI soundcard feeding an EMU APS SPDIF\" only provides MIDI clock for start/stop sync, it\'s not exactly suppling what you try to do.
    The best solution for your case is that you will need better Multi-client soundcard which is also supported GSIF in multiple outputs (8~32, more are better). Then you can run the GigaStudio within a single PC.
    Just a thought!
    LHong

  6. #6

    Re: odd GigaStudio160 behavior

    >>>>
    Now the wierd part: when I start to add NFXs, (beginning from the second one, or even from the first one turned on) bad glitches occures!!
    <<<<

    Unfortunately, the NFX plugins require more cpu power AND require it at the ring 0 level (lowest operating level of the cpu -- it\'s where the heart of GS engine is). This means that more processing time is taken away from the ring 3 level -- where operation of programs take place -- so now you lose a lot of available processing time for various Windows processes which are trying harder to keep up, hence the crackle and glitches.

    There\'s not much one can do to remedy this, other than buying a faster CPU.

  7. #7
    Senior Member LHong's Avatar
    Join Date
    May 2000
    Location
    San Jose, Ca, USA
    Posts
    542

    Re: odd GigaStudio160 behavior

    ============================================
    There\'s not much one can do to remedy this, other than buying a faster CPU.
    ============================================

    Well, Everyone try to push the CPU works so hard since our CPU is not 5Ghz neither 2GBM_DRAM. I\'ve seen many soundcards are available in the market desn\'t tax to CPU that much (10~20%). We\'ve all spent much time for the optimizations but soon or later it will hit to the limit again. Let\'s say you have about 20~32 audio tracks, how the CPU could handles it. Don\'t tell me that you will need a 2GHZ-PC system.
    Just another thought! anyone\'s comments?
    LHong


  8. #8

    Re: odd GigaStudio160 behavior

    I very much appreciate your suggestions.

    * VCache: I tried every settings from 0 to 49k - the best is 0.

    * Still a little attenuation is improving the performance (-3..-6dB). Of course that -15dB is not acceptable it was ONLY for testings

    * all the IDE channels/PCI issues are carefuly tuned

    * I do not need SMPTE or other synchronizations, since I am using CUBASE VST on one PC and the GSt on the other (no other sequencer here). I only use MIDI links between the computers and, of course, the SPDIF signals.

    ** Yes, killerbobjr, I have the same feeling: it might be the CPU. It is a Pentium-3/700MHz FLIP processor (that has only 256KB L2 cache memory but which runs at the full speed - 700MHz, I guess??). Since my board is a SLOT-1 type, I am using also an adapter from socket to slot-1. Can this be the problem?
    Weird is that even with 3-4 NFX activated and with Giga Harp AND GigaPiano loaded, the CPU load does NOT exceed 50%. So it still seems to be ok?

    *******************
    I am seriously considering the idea of switching from the actual Windows98SE to the Windows95 OSR2 which is less CPU consumer, but I heard a rumour that Win95 does not support CPUs over 350MHz - for a stable running. What do you guys think?

    thanks again,

    mihmar

  9. #9

    Re: odd GigaStudio160 behavior

    <BLOCKQUOTE><font size=\"1\" face=\"Verdana, Arial\">quote:</font><HR> I am seriously considering the idea of switching from the actual Windows98SE to the Windows95 OSR2 which is less CPU consumer, but I heard a rumour that Win95 does not support CPUs over 350MHz - for a stable running. What do you guys think? <HR></BLOCKQUOTE>

    Consider 98Lite by Shane Brooks as suggested previously elsewhere. It did remove a lot of clutter in my Windows 98 and I get a more stable system. I now run Windows 98 without any trace of Internet Explorer and in a Windows 95 shell.

    The link: http://www.98lite.net/98lite.html


  10. #10
    Senior Member LHong's Avatar
    Join Date
    May 2000
    Location
    San Jose, Ca, USA
    Posts
    542

    Re: odd GigaStudio160 behavior

    ==========================================
    * VCache: I tried every settings from 0 to 49k - the best is 0.
    ...* I do not need SMPTE or other synchronizations, since I am using CUBASE VST on one PC and the GSt on the other (no other sequencer here). I only use MIDI links between the computers and, of course, the SPDIF signals.
    ===========================================
    It sounds so intested about your Vcache is 0, something is wrong here! the Giga must works harder...
    Anyway, you are right, you don\'t need any kind of MIDI synchronization when you just use only Cubase VST (I was wrong). So you must use the MIDI I/O to remote the GigaStudio. correct me if I\'m wrong! One more thing, I\'d like to learn and share with you, see as follows:
    Honestly, I don\'t see the advantage why you want to seperate two PCs (Giga and Audio-Seq). In this case you must have double everything (completed-two-systems) and the SPDIF just only carring one stereo signal (L/R). It does mean very little, if someone provides you 18 of those (2-ADAT+ SPDIF), is that helpful for you.
    If you want 20~30 audio + 10 MIDI tracks in your sequencer (thru. Giga), how you do that? how about mixdown these tracks?
    Maybe you\'ve never thought about it! If you are interest, there might be some way you can do it within a single PC. There are many available DSP-soundcards in the martket, it doesn\'t tax to your CPU, you can mix with all kind of effects without any problems. Think about it! (don\'t forget, CPU is not 5Ghz)
    I just try to help. If we Try to get better PCs, optimize OS, better softwares...still not enough. we should get the good and right hardware for it! It doesn\'t mean more expensive (how much your second PC cost? how much for the studio space your (2nd-PC) rent? Just a joke!
    Regards,
    LHong


Go Back to forum

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •